ppc44x: fix build of crypto4xx_core.c
[openwrt/openwrt.git] / rules.mk
index 41e0ef23437b73b130ed211207b4fb0aec84e9a8..b1d9926270eb5d74f0e1e90fff2eb16163778d73 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -55,6 +55,8 @@ __tr_template = $(__tr_head)$$(1)$(__tr_tail)
 $(eval toupper = $(call __tr_template,$(chars_lower),$(chars_upper)))
 $(eval tolower = $(call __tr_template,$(chars_upper),$(chars_lower)))
 
+version_abbrev = $(if $(if $(CHECK),,$(DUMP)),$(1),$(shell printf '%.8s' $(1)))
+
 _SINGLE=export MAKEFLAGS=$(space);
 CFLAGS:=
 ARCH:=$(subst i486,i386,$(subst i586,i386,$(subst i686,i386,$(call qstrip,$(CONFIG_ARCH)))))