ath9k: fix a few issues with pa predistortion on ar9003
[openwrt/openwrt.git] / rules.mk
index c0004d808832ae3a2c85a7c94efe44a5affac1c9..d3521649a52da662301b3f29eafc6486fe60e3b5 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -47,6 +47,8 @@ else
   FPIC:=-fpic
 endif
 
+HOST_FPIC:=-fPIC
+
 ARCH_SUFFIX:=
 ifneq ($(findstring -mips32r2,$(TARGET_OPTIMIZATION)),)
   ARCH_SUFFIX:=_r2
@@ -160,7 +162,7 @@ HOST_LDFLAGS:=-L$(STAGING_DIR_HOST)/lib
 
 TARGET_CC:=$(TARGET_CROSS)gcc
 TARGET_CXX:=$(if $(CONFIG_INSTALL_LIBSTDCPP),$(TARGET_CROSS)g++,no)
-PATCH:=$(SCRIPT_DIR)/patch-kernel.sh
+KPATCH:=$(SCRIPT_DIR)/patch-kernel.sh
 SED:=$(STAGING_DIR_HOST)/bin/sed -i -e
 CP:=cp -fpR
 LN:=ln -sf
@@ -247,6 +249,16 @@ define include_mk
 $(eval -include $(if $(DUMP),,$(STAGING_DIR)/mk/$(strip $(1))))
 endef
 
+# Execute commands under flock
+# $(1) => The shell expression.
+# $(2) => The lock name. If not given, the global lock will be used.
+define locked
+       SHELL= \
+       $(STAGING_DIR_HOST)/bin/flock \
+               $(TMP_DIR)/.$(if $(2),$(strip $(2)),global).flock \
+               -c '$(subst ','\'',$(1))'
+endef
+
 # file extension
 ext=$(word $(words $(subst ., ,$(1))),$(subst ., ,$(1)))
 
@@ -254,4 +266,16 @@ all:
 FORCE: ;
 .PHONY: FORCE
 
+val.%:
+       @$(if $(filter undefined,$(origin $*)),\
+               echo "$* undefined" >&2, \
+               echo '$(subst ','"'"',$($*))' \
+       )
+
+var.%:
+       @$(if $(filter undefined,$(origin $*)),\
+               echo "$* undefined" >&2, \
+               echo "$*='"'$(subst ','"'\"'\"'"',$($*))'"'" \
+       )
+
 endif #__rules_inc