tools/findutils: include sysmacros.h explicitly
[openwrt/openwrt.git] / rules.mk
index a3fe50b1dc0dfb4d1586ceb5bbf85a3fd36f5ebf..ed796a54024adc4d4cbcb13d46a03bf6e0c1c8f5 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -29,7 +29,7 @@ empty:=
 space:= $(empty) $(empty)
 comma:=,
 merge=$(subst $(space),,$(1))
-confvar=$(call merge,$(foreach v,$(1),$(if $($(v)),y,n)))
+confvar=$(shell echo '$(foreach v,$(1),$(v)=$(subst ','\'',$($(v))))' | $(STAGING_DIR_HOST)/bin/mkhash md5)
 strip_last=$(patsubst %.$(lastword $(subst .,$(space),$(1))),%,$(1))
 
 paren_left = (