scripts: ipkg-remove: handle existing .ipk files without SourceName field
[openwrt/openwrt.git] / scripts / checkpatch.pl
index 9858e62fbbd41b920020a79de6c8b8aff1101d51..5224ea49c3b27985c3d15928c2748467dce4fdd4 100755 (executable)
@@ -1,4 +1,4 @@
-#!/usr/bin/perl -w
+#!/usr/bin/env perl 
 # (c) 2001, Dave Jones. (the file handling bit)
 # (c) 2005, Joel Schopp <jschopp@austin.ibm.com> (the ugly bit)
 # (c) 2007,2008, Andy Whitcroft <apw@uk.ibm.com> (new conditions, test suite)
@@ -7,6 +7,7 @@
 # Licensed under the terms of the GNU GPL License version 2
 
 use strict;
+use warnings;
 
 my $P = $0;
 $P =~ s@.*/@@g;
@@ -173,7 +174,7 @@ if ($tree) {
        }
 
        if (!defined $root) {
-               print "Must be run from the top-level dir. of a LEDE tree\n";
+               print "Must be run from the top-level dir. of a OpenWrt tree\n";
                exit(2);
        }
 }
@@ -391,7 +392,7 @@ sub top_of_openwrt_tree {
 
        my @tree_check = (
                "BSDmakefile", "Config.in", "LICENSE", "Makefile", "README",
-               "docs", "feeds.conf.default", "include", "package", "rules.mk",
+               "feeds.conf.default", "include", "package", "rules.mk",
                "scripts", "target", "toolchain", "tools"
        );