iw: update to version 4.14
[openwrt/openwrt.git] / scripts / deptest.sh
index 762821a39cb078a278c55f88fd24f95af532683e..03da9f568e7748311d0814945b2fa0fce82821a8 100755 (executable)
@@ -1,4 +1,4 @@
-#!/bin/bash
+#!/usr/bin/env bash
 #
 # Automated OpenWrt package dependency checker
 #
@@ -7,10 +7,6 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# Usage:
-#   No commandline arguments => check dependencies of all installed packages
-#   Package name(s) as arguments => only test the specified packages
-#
 
 SCRIPTDIR="$(dirname "$0")"
 [ "${SCRIPTDIR:0:1}" = "/" ] || SCRIPTDIR="$PWD/$SCRIPTDIR"
@@ -22,10 +18,13 @@ STAMP_DIR_FAILED="$DIR/stamp-failed"
 STAMP_DIR_BLACKLIST="$DIR/stamp-blacklist"
 BUILD_DIR="$DIR/build_dir/target"
 BUILD_DIR_HOST="$DIR/build_dir/host"
-STAGING_DIR="$DIR/staging_dir"
-STAGING_DIR_HOST="$DIR/staging_dir_host"
+KERNEL_BUILD_DIR="$DIR/build_dir/linux"
+STAGING_DIR="$DIR/staging_dir/target"
+STAGING_DIR_HOST="$DIR/staging_dir/host"
 STAGING_DIR_HOST_TMPL="$DIR/staging_dir_host_tmpl"
-LOG_DIR="$DIR/logs"
+BIN_DIR="$DIR/staging_dir/bin_dir"
+LOG_DIR_NAME="logs"
+LOG_DIR="$DIR/$LOG_DIR_NAME"
 
 die()
 {
@@ -33,10 +32,58 @@ die()
        exit 1
 }
 
+usage()
+{
+       echo "deptest.sh [OPTIONS] [PACKAGES]"
+       echo
+       echo "OPTIONS:"
+       echo "  --lean       Run a lean test. Do not clean the build directory for each"
+       echo "               package test."
+       echo "  --force      Force a test, even if a success/blacklist stamp is available"
+       echo "  -j X         Number of make jobs"
+       echo
+       echo "PACKAGES are packages to test. If not specified, all installed packages"
+       echo "will be tested."
+}
+
+deptest_make()
+{
+       local target="$1"
+       shift
+       local logfile="$1"
+       shift
+       make -j$nrjobs "$target" \
+               BUILD_DIR="$BUILD_DIR" \
+               BUILD_DIR_HOST="$BUILD_DIR_HOST" \
+               KERNEL_BUILD_DIR="$KERNEL_BUILD_DIR" \
+               BIN_DIR="$BIN_DIR" \
+               STAGING_DIR="$STAGING_DIR" \
+               STAGING_DIR_HOST="$STAGING_DIR_HOST" \
+               FORCE_HOST_INSTALL=1 \
+               V=99 "$@" >"$LOG_DIR/$logfile" 2>&1
+}
+
+clean_kernel_build_dir()
+{
+       # delete everything, except the kernel build dir "linux-X.X.X"
+       (
+               cd "$KERNEL_BUILD_DIR" || die "Failed to enter kernel build dir"
+               for entry in *; do
+                       [ -z "$(echo "$entry" | egrep -e '^linux-*.*.*$')" ] || continue
+                       rm -rf "$entry" || die "Failed to clean kernel build dir"
+               done
+       )
+}
+
+stamp_exists() # $1=stamp
+{
+       [ -e "$1" -o -L "$1" ]
+}
+
 test_package() # $1=pkgname
 {
        local pkg="$1"
-       [ -z "$(echo "$pkg" | grep -e '/')" -a "$pkg" != "." -a "$pkg" != ".." ] || \
+       [ -n "$pkg" -a -z "$(echo "$pkg" | grep -e '/')" -a "$pkg" != "." -a "$pkg" != ".." ] || \
                die "Package name \"$pkg\" contains illegal characters"
        local SELECTED=
        for conf in `grep CONFIG_PACKAGE tmp/.packagedeps | grep -E "[ /]$pkg\$" | sed -e 's,package-$(\(CONFIG_PACKAGE_.*\)).*,\1,'`; do
@@ -46,34 +93,67 @@ test_package() # $1=pkgname
        local STAMP_FAILED="$STAMP_DIR_FAILED/$pkg"
        local STAMP_BLACKLIST="$STAMP_DIR_BLACKLIST/$pkg"
        rm -f "$STAMP_FAILED"
-       [ -f "$STAMP_SUCCESS" ] && return
+       stamp_exists "$STAMP_SUCCESS" && [ $force -eq 0 ] && return
+       rm -f "$STAMP_SUCCESS"
        [ -n "$SELECTED" ] || {
                echo "Package $pkg is not selected"
                return
        }
-       [ -f "$STAMP_BLACKLIST" ] && {
+       stamp_exists "$STAMP_BLACKLIST" && [ $force -eq 0 ] && {
                echo "Package $pkg is blacklisted"
                return
        }
        echo "Testing package $pkg..."
-       rm -rf "$STAGING_DIR"
+       rm -rf "$STAGING_DIR" "$STAGING_DIR_HOST"
        mkdir -p "$STAGING_DIR"
-       rm -rf "$STAGING_DIR_HOST"
        cp -al "$STAGING_DIR_HOST_TMPL" "$STAGING_DIR_HOST"
-       make package/$pkg/compile \
-               BUILD_DIR="$BUILD_DIR" \
-               BUILD_DIR_HOST="$BUILD_DIR_HOST" \
-               STAGING_DIR="$STAGING_DIR" \
-               STAGING_DIR_HOST="$STAGING_DIR_HOST" \
-               V=99 >"$LOG_DIR/$(basename $pkg).log" 2>&1
+       [ $lean_test -eq 0 ] && {
+               rm -rf "$BUILD_DIR" "$BUILD_DIR_HOST"
+               clean_kernel_build_dir
+       }
+       mkdir -p "$BUILD_DIR" "$BUILD_DIR_HOST"
+       local logfile="$(basename $pkg).log"
+       deptest_make "package/$pkg/compile" "$logfile"
        if [ $? -eq 0 ]; then
-               touch "$STAMP_SUCCESS"
+               ( cd "$STAMP_DIR_SUCCESS"; ln -s "../$LOG_DIR_NAME/$logfile" "./$pkg" )
        else
-               touch "$STAMP_FAILED"
-               echo "Building package $pkg failed!"
+               ( cd "$STAMP_DIR_FAILED"; ln -s "../$LOG_DIR_NAME/$logfile" "./$pkg" )
+               echo "Building package $pkg FAILED"
        fi
 }
 
+# parse commandline options
+packages=
+lean_test=0
+force=0
+nrjobs=1
+while [ $# -ne 0 ]; do
+       case "$1" in
+       --help|-h)
+               usage
+               exit 0
+               ;;
+       --lean)
+               lean_test=1
+               ;;
+       --force)
+               force=1
+               ;;
+       -j*)
+               if [ -n "${1:2}" ]; then
+                       nrjobs="${1:2}"
+               else
+                       shift
+                       nrjobs="$1"
+               fi
+               ;;
+       *)
+               packages="$packages $1"
+               ;;
+       esac
+       shift
+done
+
 [ -f "$BASEDIR/include/toplevel.mk" ] || \
        die "Error: Could not find buildsystem base directory"
 [ -f "$BASEDIR/.config" ] || \
@@ -81,25 +161,51 @@ test_package() # $1=pkgname
 cd "$BASEDIR" || die "Failed to enter base directory"
 
 mkdir -p "$STAMP_DIR_SUCCESS" "$STAMP_DIR_FAILED" "$STAMP_DIR_BLACKLIST" \
-       "$BUILD_DIR" "$BUILD_DIR_HOST" "$LOG_DIR"
+       "$BIN_DIR" "$LOG_DIR"
+
+bootstrap_deptest_make()
+{
+       local target="$1"
+       shift
+       local logfile="bootstrap-deptest-$(echo "$target" | tr / -).log"
+       echo "deptest-make $target"
+       deptest_make "$target" "$logfile" "$@" || \
+               die "make $target failed, please check $logfile"
+}
+
+bootstrap_native_make()
+{
+       local target="$1"
+       shift
+       local logfile="bootstrap-native-$(echo "$target" | tr / -).log"
+       echo "make $target"
+       make -j$nrjobs "$target" \
+               V=99 "$@" >"$LOG_DIR/$logfile" 2>&1 || \
+               die "make $target failed, please check $logfile"
+}
 
 [ -d "$STAGING_DIR_HOST_TMPL" ] || {
-       rm -rf staging_dir/host
-       make tools/install V=99 || die "make tools/install failed, please check"
-       cp -al staging_dir/host "$STAGING_DIR_HOST_TMPL"
-       make toolchain/install V=99 || die "make toolchain/install failed, please check"
-       make target/linux/install V=99 || die "make target/linux/install failed, please check"
+       echo "Bootstrapping build environment..."
+       rm -rf "$STAGING_DIR" "$STAGING_DIR_HOST" "$BUILD_DIR" "$BUILD_DIR_HOST" "$KERNEL_BUILD_DIR"
+       mkdir -p "$STAGING_DIR" "$STAGING_DIR_HOST" \
+               "$BUILD_DIR" "$BUILD_DIR_HOST" "$KERNEL_BUILD_DIR"
+       bootstrap_native_make tools/install
+       bootstrap_native_make toolchain/install
+       bootstrap_deptest_make tools/install
+       bootstrap_deptest_make target/linux/install
+       cp -al "$STAGING_DIR_HOST" "$STAGING_DIR_HOST_TMPL"
+       rm -rf "$STAGING_DIR" "$STAGING_DIR_HOST" "$BUILD_DIR" "$BUILD_DIR_HOST"
+       echo "Build environment OK."
 }
 
-if [ $# -eq 0 ]; then
+if [ -z "$packages" ]; then
        # iterate over all packages
        for pkg in `cat tmp/.packagedeps  | grep CONFIG_PACKAGE | grep -v curdir | sed -e 's,.*[/=]\s*,,' | sort -u`; do
                test_package "$pkg"
        done
 else
-       # Only check the specified packages
-       while [ $# -ne 0 ]; do
-               test_package "$1"
-               shift
+       # only check the specified packages
+       for pkg in $packages; do
+               test_package "$pkg"
        done
 fi