brcm2708-gpu-fw: update to latest version
[openwrt/openwrt.git] / scripts / feeds
index 785be38..045835c 100755 (executable)
@@ -1,4 +1,4 @@
-#!/usr/bin/perl
+#!/usr/bin/env perl
 use Getopt::Std;
 use FindBin;
 use Cwd;
@@ -22,7 +22,10 @@ my @mkver = split /\s+/, `$mk -v`, 4;
 my $valid_mk = 1;
 $mkver[0] =~ /^GNU/ or $valid_mk = 0;
 $mkver[1] =~ /^Make/ or $valid_mk = 0;
-$mkver[2] >= "3.81" or $valid_mk = 0;
+
+my ($mkv1, $mkv2) = split /\./, $mkver[2];
+($mkv1 >= 4 || ($mkv1 == 3 && $mkv2 >= 81)) or $valid_mk = 0;
+
 $valid_mk or die "Unsupported version of make found: $mk\n";
 
 my @feeds;
@@ -51,7 +54,7 @@ sub parse_config() {
                $line++;
 
                my $valid = 1;
-               $line[0] =~ /^src-\w+$/ or $valid = 0;
+               $line[0] =~ /^src-[\w-]+$/ or $valid = 0;
                $line[1] =~ /^\w+$/ or $valid = 0;
                @src = split /\s+/, $line[2];
                $valid or die "Syntax error in feeds.conf, line: $line\n";
@@ -128,6 +131,13 @@ my %update_method = (
                'update'        => "git pull --ff",
                'controldir'    => ".git",
                'revision'      => "git show --abbrev-commit HEAD | head -n 1 | cut -d ' ' -f 2 | tr -d '\n'"},
+       'src-git-full' => {
+               'init'          => "git clone '%s' '%s'",
+               'init_branch'   => "git clone --branch '%s' '%s' '%s'",
+               'init_commit'   => "git clone '%s' '%s' && cd '%s' && git checkout -b '%s' '%s' && cd -",
+               'update'        => "git pull --ff",
+               'controldir'    => ".git",
+               'revision'      => "git show --abbrev-commit HEAD | head -n 1 | cut -d ' ' -f 2 | tr -d '\n'"},
        'src-gitsvn' => {
                'init'  => "git svn clone -r HEAD '%s' '%s'",
                'update'        => "git svn rebase",
@@ -307,7 +317,7 @@ sub list_feed {
 sub list {
        my %opts;
 
-       getopts('r:d:nsh', \%opts);
+       getopts('r:d:nshf', \%opts);
        if ($opts{h}) {
                usage();
                return 0;
@@ -335,6 +345,14 @@ sub list {
                        if ($opts{d}) {
                                printf "%s%s%s%s%s%s%s\n", $feed->[1], $opts{d}, $feed->[0], $opts{d}, $revision, $opts{d}, join(", ", @{$feed->[2]});
                        }
+                       elsif ($opts{f}) {
+                               my $uri = join(", ", @{$feed->[2]});
+                               if ($revision ne "local" && $revision ne "X") {
+                                       $uri =~ s/[;^].*//;
+                                       $uri .= "^" . $revision;
+                               }
+                               printf "%s %s %s\n", $feed->[0], $feed->[1], $uri;
+                       }
                        else {
                                printf "\%-8s \%-8s \%-8s \%s\n", $feed->[1], $feed->[0], $revision, join(", ", @{$feed->[2]});
                        }
@@ -383,7 +401,7 @@ sub do_install_target($) {
 
                system("ln -sf ../../$path ./target/linux/");
        } else {
-               warn "Package is not valid\n";
+               warn "Target is not valid\n";
                return 1;
        }
 
@@ -443,10 +461,10 @@ sub install_package {
        my $force = shift;
        my $ret = 0;
 
-       $feed = lookup_target($feed, $name);
-       $feed and do {
+       my $this_feed_target = lookup_target($feed, $name);
+       $this_feed_target and do {
                $installed_targets{$name} and return 0;
-               install_target($feed, $name);
+               install_target($this_feed_target, $name);
                return 0;
        };
 
@@ -490,8 +508,8 @@ sub install_package {
        $installed{$src} = 1;
 
        defined($override) and $override == 1
-               and warn "Overriding package '$src'\n"
-               or warn "Installing package '$src'\n";
+               and warn "Overriding core package '$src' with version from $feed->[1]\n"
+               or warn "Installing package '$src' from $feed->[1]\n";
 
        do_install_package($feed, $pkg) == 0 or do {
                warn "failed.\n";
@@ -516,6 +534,11 @@ sub install_package {
 sub refresh_config {
        my $default = shift;
 
+       # Don't create .config if it doesn't already exist so that making a
+       # config only occurs when the user intends it do (however we do
+       # want to refresh an existing config).
+       return if not (-e '.config');
+
        # workaround for timestamp check
        system("rm -f tmp/.packageinfo");
 
@@ -680,6 +703,7 @@ sub update {
        my %opts;
        my $feed_name;
        my $perform_update=1;
+       my $failed=0;
 
        $ENV{SCAN_COOKIE} = $$;
        $ENV{OPENWRT_VERBOSE} = 's';
@@ -704,8 +728,7 @@ sub update {
        if ( ($#ARGV == -1) or $opts{a}) {
                foreach my $feed (@feeds) {
                        my ($type, $name, $src) = @$feed;
-                       next unless update_feed($type, $name, $src, $perform_update) == 1;
-                       last;
+                       update_feed($type, $name, $src, $perform_update) == 0 or $failed=1;
                }
        } else {
                while ($feed_name = shift @ARGV) {
@@ -714,14 +737,14 @@ sub update {
                                if($feed_name ne $name) {
                                        next;
                                }
-                               update_feed($type, $name, $src, $perform_update);
+                               update_feed($type, $name, $src, $perform_update) == 0 or $failed=1;
                        }
                }
        }
 
        refresh_config();
 
-       return 0;
+       return $failed;
 }
 
 sub feed_config() {
@@ -751,6 +774,7 @@ Commands:
            -s :            List of feed names and their URL.
            -r <feedname>:  List packages of specified feed.
            -d <delimiter>: Use specified delimiter to distinguish rows (default: spaces)
+           -f :            List feeds in feeds.conf compatible format (when using -s).
 
        install [options] <package>: Install a package
        Options:
@@ -786,7 +810,7 @@ my %commands = (
        'uninstall' => \&uninstall,
        'feed_config' => \&feed_config,
        'clean' => sub {
-               system("rm -rf feeds");
+               system("rm -rf ./feeds ./package/feeds");
        }
 );