build: allow overriding default selection state for devices
[openwrt/openwrt.git] / scripts / metadata.pm
index 8cc7530a1d25b251c33a504028cda14241f527d1..1826a040a1165032f49a64f10de40ed0d75f97fe 100644 (file)
@@ -2,14 +2,12 @@ package metadata;
 use base 'Exporter';
 use strict;
 use warnings;
-our @EXPORT = qw(%package %srcpackage %category %subdir %preconfig %features %overrides clear_packages parse_package_metadata parse_target_metadata get_multiline @ignore %usernames %groupnames);
+our @EXPORT = qw(%package %vpackage %srcpackage %category %overrides clear_packages parse_package_metadata parse_target_metadata get_multiline @ignore %usernames %groupnames);
 
 our %package;
-our %preconfig;
+our %vpackage;
 our %srcpackage;
 our %category;
-our %subdir;
-our %features;
 our %overrides;
 our @ignore;
 
@@ -133,6 +131,7 @@ sub parse_target_metadata($) {
                /^Target-Optimization:\s*(.+)\s*$/ and $target->{cflags} = $1;
                /^CPU-Type:\s*(.+)\s*$/ and $target->{cputype} = $1;
                /^Linux-Version:\s*(.+)\s*$/ and $target->{version} = $1;
+               /^Linux-Testing-Version:\s*(.+)\s*$/ and $target->{testing_version} = $1;
                /^Linux-Release:\s*(.+)\s*$/ and $target->{release} = $1;
                /^Linux-Kernel-Arch:\s*(.+)\s*$/ and $target->{karch} = $1;
                /^Default-Subtarget:\s*(.+)\s*$/ and $target->{def_subtarget} = $1;
@@ -141,19 +140,25 @@ sub parse_target_metadata($) {
                        $profile = {
                                id => $1,
                                name => $1,
+                               has_image_metadata => 0,
+                               supported_devices => [],
                                priority => 999,
-                               packages => []
+                               packages => [],
+                               default => "y if TARGET_ALL_PROFILES"
                        };
                        $1 =~ /^DEVICE_/ and $target->{has_devices} = 1;
                        push @{$target->{profiles}}, $profile;
                };
                /^Target-Profile-Name:\s*(.+)\s*$/ and $profile->{name} = $1;
+               /^Target-Profile-hasImageMetadata:\s*(\d+)\s*$/ and $profile->{has_image_metadata} = $1;
+               /^Target-Profile-SupportedDevices:\s*(.+)\s*$/ and $profile->{supported_devices} = [ split(/\s+/, $1) ];
                /^Target-Profile-Priority:\s*(\d+)\s*$/ and do {
                        $profile->{priority} = $1;
                        $target->{sort} = 1;
                };
                /^Target-Profile-Packages:\s*(.*)\s*$/ and $profile->{packages} = [ split(/\s+/, $1) ];
                /^Target-Profile-Description:\s*(.*)\s*/ and $profile->{desc} = get_multiline(*FILE);
+               /^Target-Profile-Default:\s*(.+)\s*$/ and $profile->{default} = $1;
        }
        close FILE;
        foreach my $target (@target) {
@@ -178,12 +183,10 @@ sub parse_target_metadata($) {
 }
 
 sub clear_packages() {
-       %subdir = ();
-       %preconfig = ();
        %package = ();
+       %vpackage = ();
        %srcpackage = ();
        %category = ();
-       %features = ();
        %overrides = ();
        %usernames = ();
        %groupnames = ();
@@ -192,10 +195,6 @@ sub clear_packages() {
 sub parse_package_metadata($) {
        my $file = shift;
        my $pkg;
-       my $feature;
-       my $makefile;
-       my $preconfig;
-       my $subdir;
        my $src;
        my $override;
        my %ignore = map { $_ => 1 } @ignore;
@@ -206,63 +205,47 @@ sub parse_package_metadata($) {
        };
        while (<FILE>) {
                chomp;
-               /^Source-Makefile: \s*((.+\/)([^\/]+)\/Makefile)\s*$/ and do {
-                       $makefile = $1;
-                       $subdir = $2;
-                       $src = $3;
-                       $subdir =~ s/^package\///;
-                       $subdir{$src} = $subdir;
-                       $srcpackage{$src} = {
+               /^Source-Makefile: \s*((?:package\/)?((?:.+\/)?([^\/]+))\/Makefile)\s*$/ and do {
+                       $src = {
+                               makefile => $1,
+                               path => $2,
+                               name => $3,
+                               ignore => $ignore{$3},
                                packages => [],
                                buildtypes => [],
                                builddepends => [],
                        };
+                       $srcpackage{$3} = $src;
                        $override = "";
                        undef $pkg;
                };
                /^Override: \s*(.+?)\s*$/ and do {
                        $override = $1;
-                       $overrides{$src} = 1;
+                       $overrides{$src->{name}} = 1;
                };
                next unless $src;
                /^Package:\s*(.+?)\s*$/ and do {
-                       undef $feature;
                        $pkg = {};
-                       $pkg->{ignore} = $ignore{$src};
                        $pkg->{src} = $src;
-                       $pkg->{makefile} = $makefile;
                        $pkg->{name} = $1;
                        $pkg->{title} = "";
                        $pkg->{depends} = [];
                        $pkg->{mdepends} = [];
-                       $pkg->{subdir} = $subdir;
+                       $pkg->{provides} = [$1];
                        $pkg->{tristate} = 1;
                        $pkg->{override} = $override;
                        $package{$1} = $pkg;
-                       push @{$srcpackage{$src}{packages}}, $pkg;
-               };
-               /^Feature:\s*(.+?)\s*$/ and do {
-                       undef $pkg;
-                       $feature = {};
-                       $feature->{name} = $1;
-                       $feature->{priority} = 0;
-               };
-               $feature and do {
-                       /^Target-Name:\s*(.+?)\s*$/ and do {
-                               $features{$1} or $features{$1} = [];
-                               push @{$features{$1}}, $feature unless $ignore{$src};
-                       };
-                       /^Target-Title:\s*(.+?)\s*$/ and $feature->{target_title} = $1;
-                       /^Feature-Priority:\s*(\d+)\s*$/ and $feature->{priority} = $1;
-                       /^Feature-Name:\s*(.+?)\s*$/ and $feature->{title} = $1;
-                       /^Feature-Description:/ and $feature->{description} = get_multiline(\*FILE, "\t\t\t");
-                       next;
+                       push @{$src->{packages}}, $pkg;
+
+                       $vpackage{$1} or $vpackage{$1} = [];
+                       unshift @{$vpackage{$1}}, $pkg;
                };
-               /^Build-Depends: \s*(.+)\s*$/ and $srcpackage{$src}{builddepends} = [ split /\s+/, $1 ];
-               /^Build-Depends\/(\w+): \s*(.+)\s*$/ and $srcpackage{$src}{"builddepends/$1"} = [ split /\s+/, $2 ];
-               /^Build-Types:\s*(.+)\s*$/ and $srcpackage{$src}{buildtypes} = [ split /\s+/, $1 ];
+               /^Build-Depends: \s*(.+)\s*$/ and $src->{builddepends} = [ split /\s+/, $1 ];
+               /^Build-Depends\/(\w+): \s*(.+)\s*$/ and $src->{"builddepends/$1"} = [ split /\s+/, $2 ];
+               /^Build-Types:\s*(.+)\s*$/ and $src->{buildtypes} = [ split /\s+/, $1 ];
                next unless $pkg;
                /^Version: \s*(.+)\s*$/ and $pkg->{version} = $1;
+               /^ABIVersion: \s*(.+)\s*$/ and $pkg->{abiversion} = $1;
                /^Title: \s*(.+)\s*$/ and $pkg->{title} = $1;
                /^Menu: \s*(.+)\s*$/ and $pkg->{menu} = $1;
                /^Submenu: \s*(.+)\s*$/ and $pkg->{submenu} = $1;
@@ -273,15 +256,11 @@ sub parse_package_metadata($) {
                /^Default: \s*(.+)\s*$/ and $pkg->{default} = $1;
                /^Provides: \s*(.+)\s*$/ and do {
                        my @vpkg = split /\s+/, $1;
+                       @{$pkg->{provides}} = ($pkg->{name}, @vpkg);
                        foreach my $vpkg (@vpkg) {
-                               $package{$vpkg} or $package{$vpkg} = {
-                                       name => $vpkg,
-                                       vdepends => [],
-                                       src => $src,
-                                       subdir => $subdir,
-                                       makefile => $makefile
-                               };
-                               push @{$package{$vpkg}->{vdepends}}, $pkg->{name};
+                               next if ($vpkg eq $pkg->{name});
+                               $vpackage{$vpkg} or $vpackage{$vpkg} = [];
+                               push @{$vpackage{$vpkg}}, $pkg;
                        }
                };
                /^Menu-Depends: \s*(.+)\s*$/ and $pkg->{mdepends} = [ split /\s+/, $1 ];
@@ -295,8 +274,8 @@ sub parse_package_metadata($) {
                /^Category: \s*(.+)\s*$/ and do {
                        $pkg->{category} = $1;
                        defined $category{$1} or $category{$1} = {};
-                       defined $category{$1}->{$src} or $category{$1}->{$src} = [];
-                       push @{$category{$1}->{$src}}, $pkg;
+                       defined $category{$1}{$src->{name}} or $category{$1}{$src->{name}} = [];
+                       push @{$category{$1}{$src->{name}}}, $pkg;
                };
                /^Description: \s*(.*)\s*$/ and $pkg->{description} = "\t\t $1\n". get_multiline(*FILE, "\t\t ");
                /^Type: \s*(.+)\s*$/ and do {
@@ -308,29 +287,16 @@ sub parse_package_metadata($) {
                };
                /^Config:\s*(.*)\s*$/ and $pkg->{config} = "$1\n".get_multiline(*FILE, "\t");
                /^Prereq-Check:/ and $pkg->{prereq} = 1;
-               /^Preconfig:\s*(.+)\s*$/ and do {
-                       my $pkgname = $pkg->{name};
-                       $preconfig{$pkgname} or $preconfig{$pkgname} = {};
-                       if (exists $preconfig{$pkgname}->{$1}) {
-                               $preconfig = $preconfig{$pkgname}->{$1};
-                       } else {
-                               $preconfig = {
-                                       id => $1
-                               };
-                               $preconfig{$pkgname}->{$1} = $preconfig unless $ignore{$src};
-                       }
-               };
-               /^Preconfig-Type:\s*(.*?)\s*$/ and $preconfig->{type} = $1;
-               /^Preconfig-Label:\s*(.*?)\s*$/ and $preconfig->{label} = $1;
-               /^Preconfig-Default:\s*(.*?)\s*$/ and $preconfig->{default} = $1;
                /^Require-User:\s*(.*?)\s*$/ and do {
                        my @ugspecs = split /\s+/, $1;
 
                        for my $ugspec (@ugspecs) {
                                my @ugspec = split /:/, $ugspec, 2;
-                               parse_package_metadata_usergroup($makefile, "user", \%usernames, \%userids, $ugspec[0]) or return 0;
-                               if (@ugspec > 1) {
-                                       parse_package_metadata_usergroup($makefile, "group", \%groupnames, \%groupids, $ugspec[1]) or return 0;
+                               if ($ugspec[0]) {
+                                       parse_package_metadata_usergroup($src->{makefile}, "user", \%usernames, \%userids, $ugspec[0]) or return 0;
+                               }
+                               if ($ugspec[1]) {
+                                       parse_package_metadata_usergroup($src->{makefile}, "group", \%groupnames, \%groupids, $ugspec[1]) or return 0;
                                }
                        }
                };