implement quilt handling for the kernel tree ... and there was much rejoicing!
[openwrt/openwrt.git] / target / Makefile
index 4853e3fbd2df3a829e4fc8d0213f4a6c182b000f..438d268b5e9ca568d26288cf2ac01c679e334d1e 100644 (file)
@@ -20,7 +20,15 @@ IMAGE_DIR:=linux/$(BOARD)-$(KERNEL)/image
 download: $(patsubst %,%-download,$(TARGETS-y))
 prepare: linux-prepare
 compile: linux-compile image_compile
-install: image_clean linux-install sdk_install image_install imagebuilder_install
+install: linux-install image_install 
+
+ifeq ($(CONFIG_SDK),y)
+install: sdk_install
+endif
+ifeq ($(CONFIG_IB),y)
+install: imagebuilder_install
+endif
+
 clean: linux-clean sdk-clean imagebuilder-clean image_clean
 
 prereq: FORCE
@@ -43,14 +51,5 @@ image_install: image_compile
 imagebuilder_install: image_install
        $(MAKE) -C imagebuilder install
 
-%-clean: FORCE
-       $(MAKE) -C $(patsubst %-clean,%,$@) clean
-%-download: FORCE
-       $(MAKE) -C $(patsubst %-download,%,$@) download
-%-prepare: FORCE
-       $(MAKE) -C $(patsubst %-prepare,%,$@) prepare
-%-compile: %-prepare
-       $(MAKE) -C $(patsubst %-compile,%,$@) compile
-%-install: %-compile
-       $(MAKE) -C $(patsubst %-install,%,$@) install
-
+%-prereq %-prepare %-download %-clean %-compile %-install %-refresh: FORCE
+       $(MAKE) -C $* $(patsubst $*-%,%,$@)