imagebuilder: make submake invocations less verbose
[openwrt/openwrt.git] / target / imagebuilder / files / Makefile
index af633b21636358c40e83ab7c83279b1733b3fb8d..baa0e1f271993d1d063c55f045cf7eaf413559f7 100644 (file)
@@ -123,9 +123,9 @@ _call_image: staging_dir/host/.prereq-build
 ifneq ($(USER_FILES),)
        $(MAKE) copy_files
 endif
-       $(MAKE) package_postinst
-       $(MAKE) build_image
-       $(MAKE) checksum
+       $(MAKE) -s package_postinst
+       $(MAKE) -s build_image
+       $(MAKE) -s checksum
 
 package_index: FORCE
        @echo
@@ -194,7 +194,7 @@ ifneq ($(PROFILE),)
   endif
 endif
        (unset PROFILE FILES PACKAGES MAKEFLAGS; \
-       $(MAKE) _call_image \
+       $(MAKE) -s _call_image \
                $(if $(PROFILE),USER_PROFILE="$(PROFILE_FILTER)") \
                $(if $(FILES),USER_FILES="$(FILES)") \
                $(if $(PACKAGES),USER_PACKAGES="$(PACKAGES)") \