base-files: remove default /etc/config/network, generate it via board.d instead
[openwrt/openwrt.git] / target / linux / Makefile
index 275085448f5d8496dc96a01b4a71937c5bcb59f3..f7bbdffbf831654ca8617277e5fd7aeb8959f416 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,23 +7,7 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/target.mk
 
-download:
-       $(MAKE) -C $(BOARD)-$(KERNEL) download
+export TARGET_BUILD=1
 
-prepare:
-       $(MAKE) -C $(BOARD)-$(KERNEL) prepare
-
-compile:
-       $(MAKE) -C $(BOARD)-$(KERNEL) compile
-
-install:
-       $(MAKE) -C $(BOARD)-$(KERNEL) install
-       
-refresh:
-       $(MAKE) -C $(BOARD)-$(KERNEL) refresh
-
-menuconfig:
-       $(MAKE) -C $(BOARD)-$(KERNEL) menuconfig
-
-clean:
-       $(MAKE) -C $(BOARD)-$(KERNEL) clean
+prereq clean download prepare compile install menuconfig nconfig oldconfig update refresh: FORCE
+       @+$(NO_TRACE_MAKE) -C $(BOARD) $@