Remove patch-cmdline from the packages and move it tools tools/. adm5120 and rb532...
[openwrt/openwrt.git] / target / linux / adm5120-2.6 / image / Makefile
index 360a87f657810257442b5cf9873fdc4ddf0914e6..ae869f60553a15cba2b01d1bf8bfdd74bda10de6 100644 (file)
@@ -77,8 +77,13 @@ define Image/Build/MyLoader
                $(IMGNAME)-$(3)-$(2).bin
 endef
 
                $(IMGNAME)-$(3)-$(2).bin
 endef
 
+define Image/cmdline/yaffs2
+root=/dev/mtdblock1 rootfstype=yaffs2 init=/etc/preinit
+endef
+
 define Image/Build/RouterBoard
        $(CP) $(KDIR)/vmlinux.elf $(IMGNAME)-vmlinux
 define Image/Build/RouterBoard
        $(CP) $(KDIR)/vmlinux.elf $(IMGNAME)-vmlinux
+       $(STAGING_DIR)/bin/patch-cmdline $(KDIR)/vmlinux.elf '$(strip $(call Image/cmdline/yaffs2)) '
 endef
 
 define Image/Build
 endef
 
 define Image/Build