mvebu: set fan_ctrl.sh only on mamba
[openwrt/openwrt.git] / target / linux / adm5120 / Makefile
index 1098e53a170c342f5a4d7fea6b87d0ceece80234..419c53434f19b3714e8218b061db6b549aa38360 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2009 OpenWrt.org
+# Copyright (C) 2007-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,13 +9,16 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=2.6.27.17
-SUBTARGETS:=router_le router_be
+FEATURES:=low_mem
+SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
+KERNEL_PATCHVER:=3.18
+
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += admswconfig hostapd-mini kmod-input-core \
-                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug
+DEFAULT_PACKAGES += admswconfig wpad-mini kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-keys-polled kmod-button-hotplug \
+                   kmod-leds-gpio kmod-ledtrig-adm5120-switch
 
 $(eval $(call BuildTarget))