Mark targets using kernel 3.18 as source-only
[openwrt/openwrt.git] / target / linux / ar7 / Makefile
index 0e6fa95d875baf54f57f309ebae643cbbea61a84..4a09aa09a421dd1ebf879a5c046c6abce5e7f8e8 100644 (file)
@@ -1,5 +1,5 @@
-# Copyright (C) 2006-2009 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,17 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=ar7
 BOARDNAME:=TI AR7
-FEATURES:=squashfs jffs2 atm
-
-LINUX_VERSION:=2.6.32.9
-
-include $(INCLUDE_DIR)/target.mk
+FEATURES:=squashfs atm low_mem source-only
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+SUBTARGETS:=generic ac49x
 
-DEFAULT_PACKAGES+= kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl \
-               kmod-acx
+KERNEL_PATCHVER:=3.18
 
 define Target/Description
        Build firmware images for TI AR7 based routers.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES+= swconfig
+
 $(eval $(call BuildTarget))