Mark targets using kernel 3.18 as source-only
[openwrt/openwrt.git] / target / linux / ar7 / Makefile
index 670729162010c61253e868adf5cb39c3a83b3aa8..4a09aa09a421dd1ebf879a5c046c6abce5e7f8e8 100644 (file)
@@ -9,18 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=ar7
 BOARDNAME:=TI AR7
-FEATURES:=squashfs atm
+FEATURES:=squashfs atm low_mem source-only
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 SUBTARGETS:=generic ac49x
 
-LINUX_VERSION:=3.10.21
-
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES+= swconfig
+KERNEL_PATCHVER:=3.18
 
 define Target/Description
        Build firmware images for TI AR7 based routers.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES+= swconfig
+
 $(eval $(call BuildTarget))