Mark targets using kernel 3.18 as source-only
[openwrt/openwrt.git] / target / linux / ar7 / Makefile
index da3e252440b35ee4abe2312a394c366ffdf3705c..4a09aa09a421dd1ebf879a5c046c6abce5e7f8e8 100644 (file)
@@ -9,18 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=ar7
 BOARDNAME:=TI AR7
-FEATURES:=squashfs jffs2 atm
+FEATURES:=squashfs atm low_mem source-only
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+SUBTARGETS:=generic ac49x
 
-LINUX_VERSION:=3.3.8
-
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES+= kmod-pppoa ppp-mod-pppoa linux-atm atm-tools br2684ctl \
-               kmod-acx-mac80211 swconfig wpad-mini
+KERNEL_PATCHVER:=3.18
 
 define Target/Description
        Build firmware images for TI AR7 based routers.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES+= swconfig
+
 $(eval $(call BuildTarget))