ar71xx: add support for MikroTik hAP ac lite
[openwrt/openwrt.git] / target / linux / ar71xx / Makefile
index 6b8dd8011393bf8b5f59a35fb3e531eecde8fc48..3f5bc672432f6f52b3a3678d51e17bb971ca6efe 100644 (file)
@@ -8,22 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx/AR7240/AR913x/AR934x
-FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-SUBTARGETS:=generic nand
+BOARDNAME:=Atheros AR7xxx/AR9xxx
+FEATURES:=usbgadget
+CPU_TYPE:=24kc
+SUBTARGETS:=generic nand mikrotik
 
-LINUX_VERSION:=2.6.39.4
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-keys-polled kmod-button-hotplug swconfig \
-       kmod-ath9k wpad-mini
-
-define Target/Description
-       Build firmware images for Atheros AR71xx/AR913x/AR934x based boards.
-endef
+       kmod-gpio-button-hotplug swconfig \
+       kmod-ath9k wpad-mini uboot-envtools
 
 $(eval $(call BuildTarget))