ar71xx: add support for RB LHG 5nD
[openwrt/openwrt.git] / target / linux / ar71xx / Makefile
index 8c7a1d653036bd2b62036f73e5ae411e3b7091c1..3f5bc672432f6f52b3a3678d51e17bb971ca6efe 100644 (file)
@@ -9,17 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ar71xx
 BOARDNAME:=Atheros AR7xxx/AR9xxx
-FEATURES:=mips16
-CPU_TYPE=34kc
+FEATURES:=usbgadget
+CPU_TYPE:=24kc
 SUBTARGETS:=generic nand mikrotik
 
-LINUX_VERSION:=3.10.17
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
-       kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev \
+       kmod-gpio-button-hotplug swconfig \
        kmod-ath9k wpad-mini uboot-envtools
 
 $(eval $(call BuildTarget))