ar71xx: add support for RB LHG 5nD
[openwrt/openwrt.git] / target / linux / ar71xx / Makefile
index db3f77097aae7b87ee453da3bbfd4d4777671ed0..3f5bc672432f6f52b3a3678d51e17bb971ca6efe 100644 (file)
@@ -9,21 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ar71xx
 BOARDNAME:=Atheros AR7xxx/AR9xxx
-FEATURES:=squashfs targz mips16
-CFLAGS:=-Os -pipe -mips32r2 -mtune=34kc -fno-caller-saves -mno-branch-likely
-SUBTARGETS:=generic nand
+FEATURES:=usbgadget
+CPU_TYPE:=24kc
+SUBTARGETS:=generic nand mikrotik
 
-LINUX_VERSION:=3.8.13
+KERNEL_PATCHVER:=4.4
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-gpio-button-hotplug kmod-wdt-ath79 swconfig \
-       kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev \
+       kmod-gpio-button-hotplug swconfig \
        kmod-ath9k wpad-mini uboot-envtools
 
-define Target/Description
-       Build firmware images for Atheros AR7xxx/AR9xxx based boards.
-endef
-
 $(eval $(call BuildTarget))