create jffs2 images
[openwrt/openwrt.git] / target / linux / ar71xx / Makefile
index 96e12a390aad225d9f4c9303e61dcd9760dcf664..5948e825c857a65626a294e959eef8cd3df04b28 100644 (file)
@@ -9,16 +9,19 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ar71xx
 BOARDNAME:=Atheros AR71xx/AR913x
-FEATURES:=squashfs tgz
+FEATURES:=squashfs jffs2 tgz
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
-LINUX_VERSION:=2.6.28.7
+LINUX_VERSION:=2.6.28.10
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini kmod-madwifi
+DEFAULT_PACKAGES += \
+       kmod-gpio-leds kmod-input-core kmod-input-polldev \
+       kmod-input-gpio-buttons kmod-button-hotplug
 
 define Target/Description
-       Build firmware images for Atheros AR71xx/AR913x based boards
+       Build firmware images for Atheros AR71xx/AR913x based boards.
 endef
 
 $(eval $(call BuildTarget))