create jffs2 images
[openwrt/openwrt.git] / target / linux / ar71xx / Makefile
index b3353f7d391b6536730b8e37aade2638938d2753..5948e825c857a65626a294e959eef8cd3df04b28 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008 OpenWrt.org
+# Copyright (C) 2008-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,20 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx
-FEATURES:=squashfs tgz broken
+BOARDNAME:=Atheros AR71xx/AR913x
+FEATURES:=squashfs jffs2 tgz
+CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
-LINUX_VERSION:=2.6.26.5
+LINUX_VERSION:=2.6.28.10
 
 include $(INCLUDE_DIR)/target.mk
 
-#DEFAULT_PACKAGES += kmod-madwifi
+DEFAULT_PACKAGES += \
+       kmod-gpio-leds kmod-input-core kmod-input-polldev \
+       kmod-input-gpio-buttons kmod-button-hotplug
 
 define Target/Description
-       Build firmware images for Atheros AR71xx based boards
+       Build firmware images for Atheros AR71xx/AR913x based boards.
 endef
 
 $(eval $(call BuildTarget))