kernel: update 3.10 to 3.10.21
[openwrt/openwrt.git] / target / linux / ar71xx / Makefile
index 43ee26173647af91efe7ce8bb8970576f31699b5..5fddd6f3fc93a4e41bc769597f5bf48f1c4dd94d 100644 (file)
@@ -9,11 +9,11 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ar71xx
 BOARDNAME:=Atheros AR7xxx/AR9xxx
-FEATURES:=squashfs targz mips16
-CFLAGS:=-Os -pipe -mips32r2 -mtune=34kc -fno-caller-saves -mno-branch-likely
-SUBTARGETS:=generic nand
+FEATURES:=mips16
+CPU_TYPE=34kc
+SUBTARGETS:=generic nand mikrotik
 
-LINUX_VERSION:=3.10.2
+LINUX_VERSION:=3.10.21
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -22,8 +22,4 @@ DEFAULT_PACKAGES += \
        kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev \
        kmod-ath9k wpad-mini uboot-envtools
 
-define Target/Description
-       Build firmware images for Atheros AR7xxx/AR9xxx based boards.
-endef
-
 $(eval $(call BuildTarget))