kernel: update 3.10 to 3.10.21
[openwrt/openwrt.git] / target / linux / ar71xx / Makefile
index d3bf6878d818ae18e35b9e81b97ce972a4e46e06..5fddd6f3fc93a4e41bc769597f5bf48f1c4dd94d 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,21 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=mips
 BOARD:=ar71xx
-BOARDNAME:=Atheros AR71xx/AR7240/AR913x
-FEATURES:=squashfs jffs2 targz
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
-SUBTARGETS:=generic nand
+BOARDNAME:=Atheros AR7xxx/AR9xxx
+FEATURES:=mips16
+CPU_TYPE=34kc
+SUBTARGETS:=generic nand mikrotik
 
-LINUX_VERSION:=2.6.32.12
+LINUX_VERSION:=3.10.21
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-buttons kmod-button-hotplug swconfig
-
-define Target/Description
-       Build firmware images for Atheros AR71xx/AR913x based boards.
-endef
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
+       kmod-ledtrig-default-on kmod-ledtrig-timer kmod-ledtrig-netdev \
+       kmod-ath9k wpad-mini uboot-envtools
 
 $(eval $(call BuildTarget))