ar71xx: fix LED defines for TP-Link TL-WR740N v6
[openwrt/openwrt.git] / target / linux / ar71xx / base-files / etc / board.d / 01_leds
index 520a5cd..59a1427 100755 (executable)
@@ -697,6 +697,23 @@ tl-wpa8630)
        ucidef_set_led_netdev "wlan" "WLAN" "$board:green:wlan" "wlan1"
        ucidef_set_led_netdev "wlan5" "WLAN5" "$board:green:wlan5" "wlan0"
        ;;
+tl-wr740n-v6|\
+tl-wr841n-v9|\
+tl-wr841n-v11|\
+tl-wr842n-v3)
+       ucidef_set_led_netdev "wan" "WAN" "tp-link:green:wan" "eth1"
+       ucidef_set_led_switch "lan1" "LAN1" "tp-link:green:lan1" "switch0" "0x10"
+       ucidef_set_led_switch "lan2" "LAN2" "tp-link:green:lan2" "switch0" "0x08"
+       ucidef_set_led_switch "lan3" "LAN3" "tp-link:green:lan3" "switch0" "0x04"
+       ucidef_set_led_switch "lan4" "LAN4" "tp-link:green:lan4" "switch0" "0x02"
+       ucidef_set_led_wlan "wlan" "WLAN" "tp-link:green:wlan" "phy0tpt"
+
+       case "$board" in
+       tl-wr842n-v3)
+               ucidef_set_led_usbdev "usb" "USB" "tp-link:green:3g" "1-1"
+               ;;
+       esac
+       ;;
 tl-wr802n-v1)
        ucidef_set_led_wlan "wlan" "WLAN" "tp-link:blue:system" "phy0tpt"
        ;;
@@ -718,22 +735,6 @@ tl-wr840n-v3)
        ucidef_set_led_switch "lan" "LAN" "tp-link:green:lan" "switch0" "0x1E"
        ucidef_set_led_wlan "wlan" "WLAN" "tp-link:green:wlan" "phy0tpt"
        ;;
-tl-wr841n-v9|\
-tl-wr841n-v11|\
-tl-wr842n-v3)
-       ucidef_set_led_netdev "wan" "WAN" "tp-link:green:wan" "eth1"
-       ucidef_set_led_switch "lan1" "LAN1" "tp-link:green:lan1" "switch0" "0x10"
-       ucidef_set_led_switch "lan2" "LAN2" "tp-link:green:lan2" "switch0" "0x08"
-       ucidef_set_led_switch "lan3" "LAN3" "tp-link:green:lan3" "switch0" "0x04"
-       ucidef_set_led_switch "lan4" "LAN4" "tp-link:green:lan4" "switch0" "0x02"
-       ucidef_set_led_wlan "wlan" "WLAN" "tp-link:green:wlan" "phy0tpt"
-
-       case "$board" in
-       tl-wr842n-v3)
-               ucidef_set_led_usbdev "usb" "USB" "tp-link:green:3g" "1-1"
-               ;;
-       esac
-       ;;
 tl-wr1043nd|\
 tl-wr1043nd-v2)
        ucidef_set_led_usbdev "usb" "USB" "tp-link:green:usb" "1-1"