ar71xx: add profile and build initramfs image for the WNDR4300
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / netgear.mk
index fe136234f6f8abfd33cf928a38df8d65c4b44c7d..ff25f695a029f35662f9d68406773273173e747c 100644 (file)
@@ -1,5 +1,5 @@
 #
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,3 +15,16 @@ define Profile/WNDR3700/Description
 endef
 
 $(eval $(call Profile,WNDR3700))
 endef
 
 $(eval $(call Profile,WNDR3700))
+
+
+define Profile/WNDR4300
+       NAME:=NETGEAR WNDR4300
+       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/WNDR4300/Description
+       Package set optimized for the NETGEAR WNDR4300
+endef
+
+$(eval $(call Profile,WNDR4300))
+