ar71xx: add profile and build image for the TP-Link TL-WR842N/ND v1 boards
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / tp-link.mk
index e2b97212bc688dc5871f7a2e2ba814891c3d033b..96ff12ae74cd432c42c39376009580b4c36a2cd5 100644 (file)
@@ -127,6 +127,17 @@ endef
 $(eval $(call Profile,TLWR841))
 
 
 $(eval $(call Profile,TLWR841))
 
 
+define Profile/TLWR842
+       NAME:=TP-LINK TL-WR842N/ND
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLWR842/Description
+       Package set optimized for the TP-LINK TL-WR842N/ND.
+endef
+$(eval $(call Profile,TLWR842))
+
+
 define Profile/TLWR941
        NAME:=TP-LINK TL-WR941N/ND
        PACKAGES:=
 define Profile/TLWR941
        NAME:=TP-LINK TL-WR941N/ND
        PACKAGES:=