ar71xx: create image for the TP-Link TL-WR740N v3
[openwrt/openwrt.git] / target / linux / ar71xx / generic / profiles / tp-link.mk
index 7efb1a3766fe643e237ef1a8ee3a73d3fa9b0172..f5a7a24a9319b56b0b68df0bfc64f57a811c2693 100644 (file)
@@ -5,9 +5,53 @@
 # See /LICENSE for more information.
 #
 
+define Profile/TLMR3220V1
+       NAME:=TP-LINK TL-MR3220 v1
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLMR3220V1/Description
+       Package set optimized for the TP-LINK TL-MR3220 v1.
+endef
+
+$(eval $(call Profile,TLMR3220V1))
+
+define Profile/TLMR3420V1
+       NAME:=TP-LINK TL-MR3420 v1
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/TLMR3420V1/Description
+       Package set optimized for the TP-LINK TL-MR3420 v1.
+endef
+
+$(eval $(call Profile,TLMR3420V1))
+
+define Profile/TLWA901NDV1
+       NAME:=TP-LINK TL-WA901ND v1
+       PACKAGES:=
+endef
+
+define Profile/TLWA901NDV1/Description
+       Package set optimized for the TP-LINK TL-WA901ND v1.
+endef
+
+$(eval $(call Profile,TLWA901NDV1))
+
+define Profile/TLWA901NDV2
+       NAME:=TP-LINK TL-WA901ND v2
+       PACKAGES:=
+endef
+
+define Profile/TLWA901NDV2/Description
+       Package set optimized for the TP-LINK TL-WA901ND v2.
+endef
+
+$(eval $(call Profile,TLWA901NDV2))
+
 define Profile/TLWR741NDV1
        NAME:=TP-LINK TL-WR741ND v1
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR741NDV1/Description
@@ -16,9 +60,33 @@ endef
 
 $(eval $(call Profile,TLWR741NDV1))
 
+define Profile/TLWR740NV1
+       NAME:=TP-LINK TL-WR740N v1
+       PACKAGES:=
+endef
+
+define Profile/TLWR740NV1/Description
+       Package set optimized for the TP-LINK TL-WR740N v1.
+endef
+
+$(eval $(call Profile,TLWR740NV1))
+
+
+define Profile/TLWR740NV3
+       NAME:=TP-LINK TL-WR740N v3
+       PACKAGES:=
+endef
+
+define Profile/TLWR740NV3/Description
+       Package set optimized for the TP-LINK TL-WR740N v3.
+endef
+
+$(eval $(call Profile,TLWR740NV3))
+
+
 define Profile/TLWR841NV15
        NAME:=TP-LINK TL-WR841N v1.5
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR841NV15/Description
@@ -29,7 +97,7 @@ $(eval $(call Profile,TLWR841NV15))
 
 define Profile/TLWR841NDV3
        NAME:=TP-LINK TL-WR841ND v3
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR841NDV3/Description
@@ -40,7 +108,7 @@ $(eval $(call Profile,TLWR841NDV3))
 
 define Profile/TLWR841NDV5
        NAME:=TP-LINK TL-WR841ND v5
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR841NDV5/Description
@@ -49,9 +117,20 @@ endef
 
 $(eval $(call Profile,TLWR841NDV5))
 
+define Profile/TLWR841NDV7
+       NAME:=TP-LINK TL-WR841ND v7
+       PACKAGES:=
+endef
+
+define Profile/TLWR841NDV7/Description
+       Package set optimized for the TP-LINK TL-WR841ND v7.
+endef
+
+$(eval $(call Profile,TLWR841NDV7))
+
 define Profile/TLWR941NDV2
        NAME:=TP-LINK TL-WR941ND v2
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR941NDV2/Description
@@ -62,7 +141,7 @@ $(eval $(call Profile,TLWR941NDV2))
 
 define Profile/TLWR941NDV3
        NAME:=TP-LINK TL-WR941ND v3
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR941NDV3/Description
@@ -73,7 +152,7 @@ $(eval $(call Profile,TLWR941NDV3))
 
 define Profile/TLWR941NDV4
        NAME:=TP-LINK TL-WR941ND v4
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR941NDV4/Description
@@ -84,7 +163,7 @@ $(eval $(call Profile,TLWR941NDV4))
 
 define Profile/TLWR1043NDV1
        NAME:=TP-LINK TL-WR1043ND v1
-       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
+       PACKAGES:=kmod-usb-core kmod-usb2 kmod-ledtrig-usbdev
 endef
 
 define Profile/TLWR1043NDV1/Description