ar71xx: build image for the Buffalo WHR-HP-G300N
[openwrt/openwrt.git] / target / linux / ar71xx / image / Makefile
index abcf6256e9ffada5ebbcc74bf5a7061e2a4e388a..3608f0789c826c1e9f8e6939577fce982a7c07f2 100644 (file)
@@ -144,6 +144,24 @@ define Image/Build/WZRHPG30XNH
        fi
 endef
 
+define Image/Build/WHRHPG300N
+       $(call MkuImageLzma,$(2),$(3))
+       $(call Sysupgrade/KR,$(1),$(2),917504,2883584)
+       if [ -e "$(call sysupname,$(1),$(2))" ]; then \
+               ( \
+                       echo -n -e "# Airstation Public Fmt1\x00\x00\x00\x00\x00\x00\x00\x00"; \
+                       dd if=$(call sysupname,$(1),$(2)); \
+               ) > $(call imgname,$(1),$(2))-tftp.bin; \
+               buffalo-enc -p $(4) -v 1.76 \
+                       -i $(call sysupname,$(1),$(2)) \
+                       -o $(KDIR)/$(2).enc; \
+               buffalo-tag -b $(4) -p $(4) -a ath -v 1.76 -m 1.01 -l mlang8 \
+                       -w 3 -c 0x80041000 -d 0x801e8000 -f 1 -r M_ \
+                       -i $(KDIR)/$(2).enc \
+                       -o $(call factoryname,$(1),$(2)); \
+       fi
+endef
+
 define Image/Build/Cameo
        $(call MkuImageLzma,$(2),$(3) $($(4)))
        $(call Sysupgrade/KR,$(1),$(2),$(5),$(6))
@@ -274,6 +292,20 @@ define Image/Build/TPLINK/initramfs
                -o $(call imgname,$(1),$(2))-uImage.bin
 endef
 
+define Image/Build/TPLINK-LZMA
+       $(call PatchKernelLzma,$(2),$(3))
+       -$(STAGING_DIR_HOST)/bin/mktplinkfw \
+               -B $(4) -N OpenWrt -V $(REVISION)\
+               -k $(KDIR)/vmlinux-$(2).bin.lzma \
+               -r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+               -o $(call factoryname,$(1),$(2))
+       -$(STAGING_DIR_HOST)/bin/mktplinkfw \
+               -B $(4) -N OpenWrt -V $(REVISION) -s \
+               -k $(KDIR)/vmlinux-$(2).bin.lzma \
+               -r $(BIN_DIR)/$(IMG_PREFIX)-root.$(1) \
+               -o $(call sysupname,$(1),$(2))
+endef
+
 define Image/Build/CyberTAN
        $(call MkuImageGzip,$(2),$(3))
        $(STAGING_DIR_HOST)/bin/trx -o $(KDIR)/image.tmp -f $(KDIR)/vmlinux-$(2).uImage \
@@ -591,6 +623,15 @@ define Image/Build/Profile/TLWR740NV1
        $(call Image/Build/Template/$(fs_64k)/$(1),TPLINK,tl-wr740n-v1,$(tlwe740nv1_cmdline),TL-WR740Nv1)
 endef
 
+tlwe740nv3_cmdline=board=TL-WR741ND console=ttyS0,115200
+define Image/Build/Profile/TLWR740NV3
+       $(call Image/Build/Template/$(fs_64k)/$(1),TPLINK,tl-wr740n-v3,$(tlwe740nv3_cmdline),TL-WR740Nv3)
+endef
+
+define Image/Build/Profile/TLWR743NDV1
+       $(call Image/Build/Template/$(fs_64k)/$(1),TPLINK,tl-wr743nd-v1,$(tlwe741ndv1_cmdline),TL-WR743NDv1)
+endef
+
 tlwr841nv15_cmdline=board=TL-WR841N-v1.5 console=ttyS0,115200
 define Image/Build/Profile/TLWR841NV15
        $(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr841n-v1.5,$(tlwr841nv15_cmdline),TL-WR841Nv1.5)
@@ -631,6 +672,11 @@ define Image/Build/Profile/TLWR1043NDV1
        $(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr1043nd-v1,$(tlwr1043nd_cmdline),TL-WR1043NDv1)
 endef
 
+tlwr703n_cmdline=board=TL-WR703N console=ttyATH0,115200
+define Image/Build/Profile/TLWR703NV1
+       $(call Image/Build/Template/$(fs_64k)/$(1),TPLINK-LZMA,tl-wr703n-v1,$(tlwr703n_cmdline),TL-WR703Nv1)
+endef
+
 wndr3700_cmdline=board=WNDR3700 console=ttyS0,115200
 wndr3700_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kernel),6656k(rootfs),64k(art)ro,7680k@0x70000(firmware)
 wndr3700v2_cmdline=board=WNDR3700v2 console=ttyS0,115200
@@ -655,6 +701,11 @@ define Image/Build/Profile/WRT160NL
        $(call Image/Build/Template/$(fs_64k)/$(1),CyberTAN,wrt160nl,$(wrt160nl_cmdline),1.00.01)
 endef
 
+whrhpg300n_cmdline=board=WHR-HP-G300N console=ttyS0,115200
+define Image/Build/Profile/WHRHPG300N
+       $(call Image/Build/Template/$(fs_64k)/$(1),WHRHPG300N,whr-hp-g300n,$(whrhpg300n_cmdline),whrhpg300n_mtdlayout,WHR-HP-G300N)
+endef
+
 wzrhpg300nh_cmdline=board=WZR-HP-G300NH console=ttyS0,115200
 define Image/Build/Profile/WZRHPG300NH
        $(call Image/Build/Template/$(fs_128k)/$(1),WZRHPG30XNH,wzr-hp-g300nh,$(wzrhpg300nh_cmdline),WZR-HP-G300NH)
@@ -675,7 +726,13 @@ define Image/Build/Profile/ZCN1523H516
        $(call Image/Build/Template/$(fs_64k)/$(1),Zcomax,zcn-1523h-5-16,$(zcn1523h516_cmdline))
 endef
 
+all0258n_cmdline=board=ALL0258N console=ttyS0,115200
+define Image/Build/Profile/ALL0258N
+       $(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,all0258n,$(all0258n_cmdline),,917504,5505024,KR)
+endef
+
 define Image/Build/Profile/Default
+       $(call Image/Build/Profile/ALL0258N,$(1))
        $(call Image/Build/Profile/AP121,$(1))
        $(call Image/Build/Profile/AP121MINI,$(1))
        $(call Image/Build/Profile/AP81,$(1))
@@ -703,6 +760,8 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLWA901NDV2,$(1))
        $(call Image/Build/Profile/TLWR741NDV1,$(1))
        $(call Image/Build/Profile/TLWR740NV1,$(1))
+       $(call Image/Build/Profile/TLWR740NV3,$(1))
+       $(call Image/Build/Profile/TLWR743NDV1,$(1))
        $(call Image/Build/Profile/TLWR841NV15,$(1))
        $(call Image/Build/Profile/TLWR841NDV3,$(1))
        $(call Image/Build/Profile/TLWR841NDV5,$(1))
@@ -711,12 +770,14 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLWR941NDV3,$(1))
        $(call Image/Build/Profile/TLWR941NDV4,$(1))
        $(call Image/Build/Profile/TLWR1043NDV1,$(1))
+       $(call Image/Build/Profile/TLWR703NV1,$(1))
        $(call Image/Build/Profile/UBNT,$(1))
        $(call Image/Build/Profile/WP543,$(1))
        $(call Image/Build/Profile/WNDR3700,$(1))
        $(call Image/Build/Profile/AP96,$(1))
        $(call Image/Build/Profile/WRT400N,$(1))
        $(call Image/Build/Profile/WRT160NL,$(1))
+       $(call Image/Build/Profile/WHRHPG300N,$(1))
        $(call Image/Build/Profile/WZRHPG300NH,$(1))
        $(call Image/Build/Profile/WZRHPAG300H,$(1))
        $(call Image/Build/Profile/ZCN1523H28,$(1))