ar71xx: reduce the size of the squashfs-4k binaries
[openwrt/openwrt.git] / target / linux / ar71xx / image / Makefile
index 3623a6268ca27bfd98a77b9ee8d35bf7dcf6d7a2..7ff7589d84d8fe5739580cb8cba86e2c96e7805e 100644 (file)
@@ -808,12 +808,11 @@ define Image/Build/Profile/Madwifi
 endef
 
 define Image/Build/squashfs
-       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
        dd if=$(KDIR)/root.squashfs of=$(KDIR)/root.squashfs-4k.tmp0 bs=4k conv=sync
        $(call add_jffs2_mark,$(KDIR)/root.squashfs-4k.tmp0)
        dd if=$(KDIR)/root.squashfs-4k.tmp0 of=$(BIN_DIR)/$(IMG_PREFIX)-root.squashfs-4k bs=4k conv=sync
-       $(call add_jffs2_mark,$(BIN_DIR)/$(IMG_PREFIX)-root.squashfs-4k)
        rm -f $(KDIR)/root.squashfs-4k.tmp0
+       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
 endef
 
 define Image/Build/Initramfs