ar71xx: add profile and build image for the ZyXEL NBG6716 board
[openwrt/openwrt.git] / target / linux / ar71xx / image / Makefile
index 6234ba2e893d4f3e694d958d43d1f8ff96d0ad84..8234f88eaa8738b1958979ef8ed659e4dff57ea5 100644 (file)
@@ -49,11 +49,11 @@ SINGLE_PROFILES:=
 # $(4)      : board name.
 # $(5)~$(7) : arguments for $(mkcmdline)
 #              board=$(1) console=$(2),$(3)
-# $(8)~$(12): extra arguments.
+# $(8)~$(14): extra arguments.
 define SingleProfile
   # $(1): action name, e.g. loader, buildkernel, squashfs, etc.
   define Image/Build/Profile/$(3)
-       $$(call Image/Build/Template/$(2)/$$(1),$(1),$(4),$$(call mkcmdline,$(5),$(6),$(7)),$(8),$(9),$(10),$(11),$(12))
+       $$(call Image/Build/Template/$(2)/$$(1),$(1),$(4),$$(call mkcmdline,$(5),$(6),$(7)),$(8),$(9),$(10),$(11),$(12),$(13),$(14))
   endef
   SINGLE_PROFILES += $(3)
 endef
@@ -149,11 +149,15 @@ endef
 endif
 
 # $(1): name of the 1st file.
+# $(2): size limit of the 1st file if it is greater than 262144, or
+#       the erase size of the flash if it is greater than zero and less
+#       than 262144
 # $(3): name of the 2nd file.
+# $(4): size limit of the 2nd file if $(2) is greater than 262144, otherwise
+#       it is the size limit of the output file
 # $(5): name of the output file.
 # $(6): padding size.
 define CatFiles
-       # $(4): size limit of the output file.
        if [ $(2) -eq 0 ]; then \
                filename="$(3)"; fstype=$$$${filename##*\.}; \
                case "$$$${fstype}" in \
@@ -174,8 +178,6 @@ define CatFiles
                        echo "Warning: $(5) is too big (> $(4) bytes)" >&2; \
                        rm -f $(5); \
                fi; \
-       # $(2): size limit of the 1st file.
-       # $(4): size limit of the 2nd file.
        else if [ $(2) -gt 262144 ]; then \
                if [ `stat -c%s "$(1)"` -gt $(2) ]; then \
                        echo "Warning: $(1) is too big (> $(2) bytes)" >&2; \
@@ -184,8 +186,6 @@ define CatFiles
                else \
                        ( dd if=$(1) bs=$(2) conv=sync; dd if=$(3) ) > $(5); \
                fi; fi; \
-       # $(2): padding size for the 2nd file.
-       # $(4): size limit of the output file.
        else \
                ( dd if=$(1) bs=$(2) conv=sync; dd if=$(3) ) > $(5); \
                if [ `stat -c%s $(5)` -gt $(4) ]; then \
@@ -285,6 +285,8 @@ wndr4300_mtdlayout=mtdparts=ar934x-nfc:256k(u-boot)ro,256k(u-boot-env)ro,256k(ca
 zcn1523h_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,6208k(rootfs),1472k(kernel),64k(configure)ro,64k(mfg)ro,64k(art)ro,7680k@0x50000(firmware)
 mynet_n600_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,64k(devdata)ro,64k(devconf)ro,15872k(firmware),64k(radiocfg)ro
 mynet_rext_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,7808k(firmware),64k(nvram)ro,64k(ART)ro,6848k@0x130000(filesystem)
+zyx_nbg6716_mtdlayout=mtdparts=spi0.0:256k(u-boot)ro,64k(env)ro,64k(RFdata)ro,-(nbu);ar934x-nfc:2048k(zyxel_rfsd),2048k(romd),1024k(header),2048k(kernel),-(ubiroot)
+
 
 define Image/BuildKernel
        cp $(KDIR)/vmlinux.elf $(VMLINUX).elf
@@ -843,13 +845,14 @@ endef
 # $(6): Board name (upper caps)
 # $(7): firmware region code (not used yet)
 # $(8): DNI Hardware version
+# $(9): suffix of the configuration file for ubinize
 define Image/Build/NetgearNAND
        $(eval firmwaresize=$(call mtdpartsize,firmware,$(4)))
        $(eval kernelsize=$(call mtdpartsize,kernel,$(4)))
        $(eval imageraw=$(KDIR_TMP)/$(2)-raw.img)
        $(CP) $(KDIR)/root.squashfs-raw $(KDIR_TMP)/root.squashfs
        echo -ne '\xde\xad\xc0\xde' > $(KDIR_TMP)/jffs2.eof
-       $(call ubinize,ubinize-$(2).ini,$(KDIR_TMP),$(KDIR_TMP)/$(2)-root.ubi,128KiB,2048,-E 5)
+       $(call ubinize,ubinize-$(9).ini,$(KDIR_TMP),$(KDIR_TMP)/$(2)-root.ubi,128KiB,2048,-E 5)
        ( \
                dd if=$(KDIR_TMP)/vmlinux-$(2).uImage; \
                dd if=$(KDIR_TMP)/$(2)-root.ubi \
@@ -880,6 +883,43 @@ ifdef CONFIG_PACKAGE_uboot-ar71xx-nbg460n_550n_550nh
 endif
 
 
+define Image/Build/ZyXELNAND/buildkernel
+       $(eval kernelsize=$(call mtdpartsize,kernel,$(5)))
+       $(call MkuImageLzma,$(2),$(3) $(5) $(6))
+       mkdir -p $(KDIR_TMP)/$(2)/image/boot
+       cp $(KDIR_TMP)/vmlinux-$(2).uImage $(KDIR_TMP)/$(2)/image/boot/vmlinux.lzma.uImage
+       $(STAGING_DIR_HOST)/bin/mkfs.jffs2 \
+               --pad=$(kernelsize) --big-endian --squash-uids -v -e 128KiB \
+               -o $(KDIR_TMP)/$(2)-kernel.jffs2 \
+               -d $(KDIR_TMP)/$(2)/image \
+               2>&1 1>/dev/null | awk '/^.+$$$$/'
+       -rm -rf $(KDIR_TMP)/$(2)
+endef
+
+define Image/Build/ZyXELNAND
+       if [ "$(1)" != "squashfs" ]; then \
+               echo Only squashfs is supported; \
+               return 0; \
+       fi
+       $(eval firmwaresize=$(call mtdpartsize,firmware,$(4)))
+       $(eval kernelsize=$(call mtdpartsize,kernel,$(4)))
+       $(eval imageraw=$(KDIR_TMP)/$(2)-raw.img)
+       $(CP) $(KDIR)/root.$(1) $(KDIR_TMP)/ubi_root.img
+       echo -ne '\xde\xad\xc0\xde' > $(KDIR_TMP)/jffs2.eof
+       $(call ubinize,ubinize-$(2).ini,$(KDIR_TMP),$(KDIR_TMP)/$(2)-root.ubi,128KiB,2048,-E 5)
+       ( \
+               dd if=$(KDIR_TMP)/$(2)-kernel.jffs2; \
+               dd if=$(KDIR_TMP)/$(2)-root.ubi \
+       ) > $(imageraw)
+       dd if=$(imageraw) of=$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1)-factory.bin \
+               bs=128k conv=sync
+       ( \
+               dd if=$(KDIR_TMP)/$(2)-kernel.jffs2; \
+               dd if=$(KDIR)/root.$(1) bs=128k conv=sync \
+       ) > $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1)-sysupgrade.bin
+endef
+
+
 Image/Build/OpenMesh/buildkernel=$(call MkuImageLzma,$(2))
 
 define Image/Build/OpenMesh
@@ -913,7 +953,7 @@ endef
 
 define Jffs2Template
   define Image/Build/Template/$(1)/jffs2-$(2)
-    $$(call Image/Build/$$(1),jffs2-$(2),$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8))
+    $$(call Image/Build/$$(1),jffs2-$(2),$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8),$$(9),$$(10))
   endef
 endef
 
@@ -926,16 +966,16 @@ define BuildTemplate
   # $(3)     : kernel command line.
   # $(4)~$(8): extra arguments.
   define Image/Build/Template/$(1)/initramfs
-    $$(call Image/Build/$$(1)/initramfs,initramfs,$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8))
+    $$(call Image/Build/$$(1)/initramfs,initramfs,$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8),$$(9),$$(10))
   endef
   define Image/Build/Template/$(1)/loader
-    $$(call Image/Build/$$(1)/loader,$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8))
+    $$(call Image/Build/$$(1)/loader,$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8),$$(9),$$(10))
   endef
   define Image/Build/Template/$(1)/buildkernel
-    $$(call Image/Build/$$(1)/buildkernel,,$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8))
+    $$(call Image/Build/$$(1)/buildkernel,,$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8),$$(9),$$(10))
   endef
   define Image/Build/Template/$(1)/squashfs
-    $$(call Image/Build/$$(1),squashfs$(2),$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8))
+    $$(call Image/Build/$$(1),squashfs$(2),$$(2),$$(3),$$(4),$$(5),$$(6),$$(7),$$(8),$$(9),$$(10))
   endef
   $(if $(3),$(foreach bs,$(3),$(eval $(call Jffs2Template,$(1),$(bs)))))
 endef
@@ -1176,7 +1216,12 @@ $(eval $(call MultiProfile,Madwifi,EAP7660D UBNTRS UBNTRSPRO UBNTLSSR71 WP543))
 endif # ifeq ($(SUBTARGET),generic)
 
 ifeq ($(SUBTARGET),nand)
-$(eval $(call SingleProfile,NetgearNAND,64k,WNDR4300,wndr4300,WNDR4300,ttyS0,115200,$$(wndr4300_mtdlayout),0x33373033,WNDR4300,"",-H 29763948+0+128+128+2x2+3x3))
+$(eval $(call SingleProfile,NetgearNAND,64k,WNDR3700V4,wndr3700v4,WNDR4300,ttyS0,115200,$$(wndr4300_mtdlayout),0x33373033,WNDR3700V4,"",-H 29763948+128+128,wndr4300))
+$(eval $(call SingleProfile,NetgearNAND,64k,WNDR4300V1,wndr4300,WNDR4300,ttyS0,115200,$$(wndr4300_mtdlayout),0x33373033,WNDR4300,"",-H 29763948+0+128+128+2x2+3x3,wndr4300))
+
+$(eval $(call SingleProfile,ZyXELNAND,128k,NBG6716,nbg6716,NBG6716,ttyS0,115200,NBG6716,$$(zyx_nbg6716_mtdlayout),ubi.mtd=ubiroot mem=256M))
+
+$(eval $(call MultiProfile,WNDR4300,WNDR3700V4 WNDR4300V1))
 endif # ifeq ($(SUBTARGET),nand)