ar71xx: build image for the Buffalo WHR-HP-GN
[openwrt/openwrt.git] / target / linux / ar71xx / image / Makefile
index b1015a1e7d236f0e5d99853236cbb704e9579c38..a4b851fe34585a9d75cf2f44d184b4ff8bbc3a5e 100644 (file)
@@ -145,17 +145,17 @@ define Image/Build/WZRHPG30XNH
 endef
 
 define Image/Build/WHRHPG300N
-       $(call MkuImageLzma,$(2),$(3))
+       $(call MkuImageLzma,$(2),$(3) $($(4)))
        $(call Sysupgrade/KR,$(1),$(2),917504,2883584)
        if [ -e "$(call sysupname,$(1),$(2))" ]; then \
                ( \
                        echo -n -e "# Airstation Public Fmt1\x00\x00\x00\x00\x00\x00\x00\x00"; \
                        dd if=$(call sysupname,$(1),$(2)); \
                ) > $(call imgname,$(1),$(2))-tftp.bin; \
-               buffalo-enc -p $(4) -v 1.76 \
+               buffalo-enc -p $(5) -v 1.76 \
                        -i $(call sysupname,$(1),$(2)) \
                        -o $(KDIR)/$(2).enc; \
-               buffalo-tag -b $(4) -p $(4) -a ath -v 1.76 -m 1.01 -l mlang8 \
+               buffalo-tag -b $(5) -p $(5) -a ath -v 1.76 -m 1.01 -l mlang8 \
                        -w 3 -c 0x80041000 -d 0x801e8000 -f 1 -r M_ \
                        -i $(KDIR)/$(2).enc \
                        -o $(call factoryname,$(1),$(2)); \
@@ -707,11 +707,22 @@ define Image/Build/Profile/WRT160NL
        $(call Image/Build/Template/$(fs_64k)/$(1),CyberTAN,wrt160nl,$(wrt160nl_cmdline),1.00.01)
 endef
 
+whrg301n_cmdline=board=WHR-G301N console=ttyS0,115200
+define Image/Build/Profile/WHRG301N
+       $(call Image/Build/Template/$(fs_64k)/$(1),WHRHPG300N,whr-g301n,$(whrg301n_cmdline),whrhpg300n_mtdlayout,WHR-G301N)
+endef
+
 whrhpg300n_cmdline=board=WHR-HP-G300N console=ttyS0,115200
+whrhpg300n_mtdlayout=mtdparts=spi0.0:248k(u-boot)ro,8k(u-boot-env)ro,896k(kernel),2816k(rootfs),64k(user_property),64k(art)ro,3712k@0x30000(firmware)
 define Image/Build/Profile/WHRHPG300N
        $(call Image/Build/Template/$(fs_64k)/$(1),WHRHPG300N,whr-hp-g300n,$(whrhpg300n_cmdline),whrhpg300n_mtdlayout,WHR-HP-G300N)
 endef
 
+whrhpgn_cmdline=board=WHR-HP-GN console=ttyS0,115200
+define Image/Build/Profile/WHRHPGN
+       $(call Image/Build/Template/$(fs_64k)/$(1),WHRHPG300N,whr-hp-gn,$(whrhpgn_cmdline),whrhpg300n_mtdlayout,WHR-HP-GN)
+endef
+
 wzrhpg300nh_cmdline=board=WZR-HP-G300NH console=ttyS0,115200
 define Image/Build/Profile/WZRHPG300NH
        $(call Image/Build/Template/$(fs_128k)/$(1),WZRHPG30XNH,wzr-hp-g300nh,$(wzrhpg300nh_cmdline),WZR-HP-G300NH)
@@ -784,7 +795,9 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/AP96,$(1))
        $(call Image/Build/Profile/WRT400N,$(1))
        $(call Image/Build/Profile/WRT160NL,$(1))
+       $(call Image/Build/Profile/WHRG301N,$(1))
        $(call Image/Build/Profile/WHRHPG300N,$(1))
+       $(call Image/Build/Profile/WHRHPGN,$(1))
        $(call Image/Build/Profile/WZRHPG300NH,$(1))
        $(call Image/Build/Profile/WZRHPAG300H,$(1))
        $(call Image/Build/Profile/ZCN1523H28,$(1))