ar71xx: build image for the Allnet ALL0258N board
[openwrt/openwrt.git] / target / linux / ar71xx / image / Makefile
index b1e4c1c04d6114020aa97ff241bd094339fc42f3..cd5a10186229689dd71a1c8753d9f323d64c98dc 100644 (file)
@@ -703,7 +703,13 @@ define Image/Build/Profile/ZCN1523H516
        $(call Image/Build/Template/$(fs_64k)/$(1),Zcomax,zcn-1523h-5-16,$(zcn1523h516_cmdline))
 endef
 
+all0258n_cmdline=board=ALL0258N console=ttyS0,115200
+define Image/Build/Profile/ALL0258N
+       $(call Image/Build/Template/$(fs_64k)/$(1),AthLzma,all0258n,$(all0258n_cmdline),,917504,5505024,KR)
+endef
+
 define Image/Build/Profile/Default
+       $(call Image/Build/Profile/ALL0258N,$(1))
        $(call Image/Build/Profile/AP121,$(1))
        $(call Image/Build/Profile/AP121MINI,$(1))
        $(call Image/Build/Profile/AP81,$(1))