ar71xx: Fix build for dap-1330-a1 board
[openwrt/openwrt.git] / target / linux / ar71xx / image / generic.mk
index a0f6326145b55b46761fec7f224a9465c6b47459..020e01f85a08b5fe858845bd4a6085b3f8ebb647 100644 (file)
@@ -36,7 +36,7 @@ define Build/mkdapimg2
        $(STAGING_DIR_HOST)/bin/mkdapimg2 \
                -i $@ -o $@.new \
                -s $(DAP_SIGNATURE) \
-               -v $(VERSION_DIST)-$(firstword $(subst -, ,$(REVISION))) \
+               -v $(VERSION_DIST)-$(firstword $(subst +, ,$(firstword $(subst -, ,$(REVISION))))) \
                -r Default \
                $(if $(1),-k $(1))
        mv $@.new $@