ar71xx: add Abicom SC1750 support
[openwrt/openwrt.git] / target / linux / ar71xx / image / generic.mk
index 02b90b0aa614c41cf1db9d28e07655f4a868a615..0214c530eecae144c06af2eb25f25cc38119b555 100644 (file)
@@ -464,6 +464,16 @@ define Device/onion-omega
 endef
 TARGET_DEVICES += onion-omega
 
+define Device/sc1750
+  DEVICE_TITLE := Abicom SC1750
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport
+  BOARDNAME = SC1750
+  IMAGE_SIZE = 15744k
+  CONSOLE = ttyS0,115200
+  MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env),15744k(firmware),128k(APConfig),128k(kplog),64k(ART)
+endef
+TARGET_DEVICES += sc1750
+
 define Device/sc300m
   DEVICE_TITLE := Abicom SC300M
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport