ar71xx/ath79: switch devices to the -ct driver and firmware
[openwrt/openwrt.git] / target / linux / ar71xx / image / generic.mk
index fedd37e219038ed33137104e43aa73c75c9cfedf..05428039d37bd40c8c16d6c58959d727b7067cf7 100644 (file)
@@ -148,7 +148,6 @@ define Device/ap91-5g
   IMAGE/sysupgrade.bin := append-rootfs | pad-rootfs |\
        pad-to $$$$(ROOTFS_SIZE) | append-kernel | check-size $$$$(IMAGE_SIZE)
 endef
-TARGET_DEVICES += ap91-5g
 
 define Device/arduino-yun
   DEVICE_TITLE := Arduino Yun
@@ -896,6 +895,16 @@ define Device/minibox-v1
 endef
 TARGET_DEVICES += minibox-v1
 
+define Device/minibox-v3.2
+  $(Device/tplink-16mlzma)
+  DEVICE_TITLE := Gainstrong MiniBox V3.2
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k-ct ath10k-firmware-qca9887-ct -swconfig
+  BOARDNAME := MINIBOX-V3.2
+  DEVICE_PROFILE := MINIBOXV32
+  TPLINK_HWID := 0x3C00010C
+endef
+TARGET_DEVICES += minibox-v3.2
+
 define Device/oolite-v1
   $(Device/minibox-v1)
   DEVICE_TITLE := GainStrong Oolite V1.0