ar71xx: fix build error when initramfs is disabled
[openwrt/openwrt.git] / target / linux / ar71xx / image / legacy.mk
index 680dece15b5d8cc794153ef577e21ca24cc911e4..b9a7f13cae27696763c92b2f9557b4814678144d 100644 (file)
@@ -1156,7 +1156,7 @@ endef
 
 define Image/Build/Profile
        $(call Image/Build/Profile/$(1),buildkernel)
-       $(call Image/Build/Profile/$(1),initramfs)
+       $(if $(CONFIG_TARGET_ROOTFS_INITRAMFS),$(call Image/Build/Profile/$(1),initramfs))
        $(call Image/Build/Profile/$(1),$(2))
 endef