ar71xx: add support for RB-941-2nD
[openwrt/openwrt.git] / target / linux / ar71xx / image / mikrotik.mk
index 000253b62266ec12bbe485d0231b74b64c7dfb79..ff14f90ca6aeb539aaf7de69bc7bcb6de69bf09c 100644 (file)
@@ -20,3 +20,22 @@ $(Device/mikrotik)
 endef
 
 TARGET_DEVICES += nand-64m nand-large
+
+define Device/rb-nor-flash-16M
+  DEVICE_PROFILE := Default
+  BLOCKSIZE := 64k
+  IMAGE_SIZE := 16000k
+  LOADER_TYPE := elf
+  KERNEL_INSTALL := 1
+  KERNEL := kernel-bin | lzma | loader-kernel | kernel2minor -s 1024 -e
+  KERNEL_INITRAMFS := kernel-bin | lzma | loader-kernel
+  IMAGES := sysupgrade.bin
+  IMAGE/sysupgrade.bin = append-rootfs | pad-rootfs | combined-image | check-size $$$$(IMAGE_SIZE)
+endef
+
+define Device/rb-941-2nd
+$(Device/rb-nor-flash-16M)
+  BOARDNAME:= rb-941-2nd
+endef
+
+TARGET_DEVICES += rb-941-2nd