ar71xx: add support for MikroTik hAP ac
[openwrt/openwrt.git] / target / linux / ar71xx / modules.mk
index 4530708de9139855734e624229972bfbb79a9993..9ead8b451cec79c8848026b3b9485a85e186ced7 100644 (file)
@@ -5,6 +5,22 @@
 # See /LICENSE for more information.
 #
 
+define KernelPackage/leds-nu801
+  SUBMENU:=$(LEDS_MENU)
+  TITLE:=Meraki MR18 LED support
+  DEPENDS:=@TARGET_ar71xx
+  KCONFIG:=CONFIG_LEDS_NU801
+  FILES:=$(LINUX_DIR)/drivers/leds/leds-nu801.ko
+  AUTOLOAD:=$(call AutoLoad,60,leds-nu801)
+endef
+
+define KernelPackage/leds-nu801/description
+ Kernel module for the nu801 LED driver used on the Meraki MR18.
+endef
+
+$(eval $(call KernelPackage,leds-nu801))
+
+
 define KernelPackage/leds-rb750
   SUBMENU:=$(LEDS_MENU)
   TITLE:=RouterBOARD 750 LED support
@@ -37,24 +53,6 @@ endef
 $(eval $(call KernelPackage,leds-wndr3700-usb))
 
 
-define KernelPackage/nand-ar934x
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Atheros AR934x NAND flash controller driver
-  KCONFIG:=\
-    CONFIG_MTD_NAND_AR934X \
-    CONFIG_MTD_NAND_AR934X_HW_ECC=y
-  DEPENDS:=@TARGET_ar71xx +kmod-nand
-  FILES:=$(LINUX_DIR)/drivers/mtd/nand/ar934x_nfc.ko
-  AUTOLOAD:=$(call AutoLoad,25,ar934x_nfc)
-endef
-
-define KernelPackage/nand-ar934x/description
-  Atheros AR934x NAND flash controller driver.
-endef
-
-$(eval $(call KernelPackage,nand-ar934x))
-
-
 define KernelPackage/spi-vsc7385
   SUBMENU:=$(SPI_MENU)
   TITLE:=Vitesse VSC7385 ethernet switch driver