at91: Renaming subtarget sama5d3 to sama5
[openwrt/openwrt.git] / target / linux / at91 / image / Makefile
index c50732c0c4926a37edc398f5373ef1ea9565c823..6e2b6b6101a91b55b433630f0d5d8fa47c609bdb 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2010 OpenWrt.org
+#
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,30 +7,61 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-define Build/Clean
-       $(MAKE) -C u-boot clean
+KERNEL_LOADADDR := 0x20008000
+
+ifeq ($(SUBTARGET),legacy)
+include ./legacy.mk
+UBIFS_OPTS := -m 2048 -e 126KiB -c 2048
+endif
+
+ifeq ($(SUBTARGET),sama5)
+include ./sama5.mk
+UBIFS_OPTS := -m 2048 -e 124KiB -c 2048
+endif
+
+define Device/Default
+  PROFILES := Default
+  FILESYSTEMS := squashfs ubifs
+  DEVICE_DTS := $(1)
+  KERNEL_NAME := zImage
+  KERNEL_SIZE := 4096k
+  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma
+  BLOCKSIZE := 128k
+  PAGESIZE := 2048
+  SUBPAGESIZE := 512
+  DTB_SIZE :=
+endef
+
+define Device/dtb
+  KERNEL := kernel-bin | lzma | uImage lzma
 endef
 
-define Build/Compile
-       if [ $(CONFIG_AT91_UBOOT) ]; then \
-               $(MAKE) -C u-boot compile; \
-       fi
+define Device/evaluation
+  KERNEL_INSTALL := 1
+  KERNEL_SUFFIX := -uImage
+  IMAGES := root.ubi
+  IMAGE/root.ubi := append-ubi
 endef
 
-define Image/Prepare
+define Device/evaluation-dtb
+  $(Device/evaluation)
+  $(Device/dtb)
+  IMAGES += dtb
+  IMAGE/dtb := install-dtb
 endef
 
-define Image/BuildKernel
-       mkimage -A arm -T kernel -C none -a 0x20008000 -e 0x20008000 -n linux-2.6 \
-               -d $(LINUX_DIR)/arch/arm/boot/Image $(BIN_DIR)/$(IMG_PREFIX)-uImage
-       if [ $(CONFIG_FLEXIBITY_ROOT) ]; then \
-               $(INSTALL_BIN) $(BIN_DIR)/$(IMG_PREFIX)-uImage $(TARGET_DIR)/uImage ; \
-       fi
+define Device/production
+  UBINIZE_OPTS := -E 5
+  IMAGES := factory.bin
+  IMAGE/factory.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
 endef
 
-define Image/Build
-       $(call Image/Build/$(1),$(1))
-       cp $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-root.$(1)
+define Device/production-dtb
+  $(Device/production)
+  $(Device/dtb)
+  DTB_SIZE := 128k
+  IMAGE/factory.bin := append-dtb | pad-to $$$$(DTB_SIZE) \
+         | append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi
 endef
 
 $(eval $(call BuildImage))