ath79: add support for YunCore XD4200 and A782
[openwrt/openwrt.git] / target / linux / ath79 / image / generic.mk
index 0c674cfe9a2e9851e82114d0e824c9a25863c554..865126549ae1af3e05cb12e8e5ee1af16dfb7b1e 100644 (file)
@@ -1040,6 +1040,28 @@ define Device/yuncore_a770
 endef
 TARGET_DEVICES += yuncore_a770
 
+define Device/yuncore_a782
+  ATH_SOC := qca9563
+  DEVICE_VENDOR := YunCore
+  DEVICE_MODEL := A782
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+  IMAGE_SIZE := 16000k
+  IMAGES += tftp.bin
+  IMAGE/tftp.bin := $$(IMAGE/sysupgrade.bin) | yuncore-tftp-header-16m
+endef
+TARGET_DEVICES += yuncore_a782
+
+define Device/yuncore_xd4200
+  ATH_SOC := qca9563
+  DEVICE_VENDOR := YunCore
+  DEVICE_MODEL := XD4200
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca9888-ct
+  IMAGE_SIZE := 16000k
+  IMAGES += tftp.bin
+  IMAGE/tftp.bin := $$(IMAGE/sysupgrade.bin) | yuncore-tftp-header-16m
+endef
+TARGET_DEVICES += yuncore_xd4200
+
 define Device/zbtlink_zbt-wd323
   ATH_SOC := ar9344
   DEVICE_VENDOR := ZBT