use immediate set in target Makefiles
[openwrt/openwrt.git] / target / linux / au1000 / Makefile
index 9c22db852478ccc88bc008c86d6b19a576185d07..debc41e978c0cf201ecb2a47289a62fd681b25e4 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2009 OpenWrt.org
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,19 +9,20 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=au1000
 BOARDNAME:=RMI/AMD AU1x00
-FEATURES:=jffs2 usb pci
-SUBTARGETS=au1500 au1550
+FEATURES:=squashfs usb pci
+SUBTARGETS:=au1500 au1550
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=2.6.30.7
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += hostapd-mini yamonenv
+KERNEL_PATCHVER:=3.18
 
 define Target/Description
        Build firmware for RMI/AMD Alchemy 1500,1550 boards
        (e.g. 4G-Systems Mesh/Access Cube, DBAu1550 ...)
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += wpad-mini yamonenv
+
 define Kernel/BuildImage
        $(call Kernel/BuildImage/Default)
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/zImage.flash.srec