use immediate set in target Makefiles
[openwrt/openwrt.git] / target / linux / au1000 / Makefile
index cb08fb5f28eced463601cf2fc8243a01fcd4f8d2..debc41e978c0cf201ecb2a47289a62fd681b25e4 100644 (file)
@@ -10,19 +10,19 @@ ARCH:=mipsel
 BOARD:=au1000
 BOARDNAME:=RMI/AMD AU1x00
 FEATURES:=squashfs usb pci
-SUBTARGETS=au1500 au1550
+SUBTARGETS:=au1500 au1550
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-KERNEL_PATCHVER:=3.10
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += wpad-mini yamonenv
+KERNEL_PATCHVER:=3.18
 
 define Target/Description
        Build firmware for RMI/AMD Alchemy 1500,1550 boards
        (e.g. 4G-Systems Mesh/Access Cube, DBAu1550 ...)
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += wpad-mini yamonenv
+
 define Kernel/BuildImage
        $(call Kernel/BuildImage/Default)
        $(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.flash.srec $(LINUX_DIR)/zImage.flash.srec