bcm53xx: switch to kernel 4.14
[openwrt/openwrt.git] / target / linux / bcm53xx / Makefile
index 023ce4e06654433fb2dd771d695b7a0e9a2a5fc0..2af1c7e719d6f55f244576cda1a2f01d5a9ae717 100644 (file)
@@ -8,21 +8,24 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=bcm53xx
-BOARDNAME:=Broadcom BCM47xx/53xx with ARM CPU
-FEATURES:=squashfs usb pci pcie gpio
+BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
+FEATURES:=squashfs nand usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
 
-LINUX_VERSION:=3.14.16
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=4.14
 
 define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
-KERNELNAME:="zImage dtbs"
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES += swconfig
+DEFAULT_PACKAGES += swconfig nvram \
+       osafeloader oseama otrx \
+       kmod-gpio-button-hotplug \
+       kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer
 
 $(eval $(call BuildTarget))