mvebu: set fan_ctrl.sh only on mamba
[openwrt/openwrt.git] / target / linux / bcm53xx / Makefile
index 703f0d055a806707d712b8e6b0a5d70eda31c22d..a98fd3923d1795f4d47a80a2138219ec939dc44e 100644 (file)
@@ -8,21 +8,24 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=bcm53xx
-BOARDNAME:=Broadcom BCM47xx/53xx with ARM CPU
-FEATURES:=squashfs usb pci pcie gpio
+BOARDNAME:=Broadcom BCM47xx/53xx (ARM)
+FEATURES:=squashfs nand usb pci pcie gpio
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
 
-LINUX_VERSION:=3.10.28
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=4.4
 
 define Target/Description
        Build firmware images for Broadcom based BCM47xx/53xx routers with ARM CPU, *not* MIPS.
 endef
 
-KERNELNAME:="zImage dtbs"
+include $(INCLUDE_DIR)/target.mk
+
+KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES += swconfig
+DEFAULT_PACKAGES += swconfig wpad-mini nvram \
+       osafeloader oseama otrx \
+       kmod-gpio-button-hotplug \
+       kmod-leds-gpio kmod-ledtrig-default-on kmod-ledtrig-timer
 
 $(eval $(call BuildTarget))