bcm53xx: enable HIGHMEM to support more than 128 MiB of RAM
[openwrt/openwrt.git] / target / linux / bcm53xx / config-3.18
index c0be3cc..d08e667 100644 (file)
@@ -45,7 +45,6 @@ CONFIG_ARM_THUMB=y
 # CONFIG_ARM_THUMBEE is not set
 CONFIG_ARM_VIRT_EXT=y
 CONFIG_ATAGS=y
-# CONFIG_AUDIT_ARCH_COMPAT_GENERIC is not set
 CONFIG_AUTO_ZRELADDR=y
 CONFIG_B53=y
 # CONFIG_B53_MMAP_DRIVER is not set
@@ -62,6 +61,7 @@ CONFIG_BCMA_HOST_PCI=y
 CONFIG_BCMA_HOST_PCI_POSSIBLE=y
 CONFIG_BCMA_HOST_SOC=y
 CONFIG_BGMAC=y
+CONFIG_BOUNCE=y
 CONFIG_CACHE_L2X0=y
 CONFIG_CACHE_PL310=y
 CONFIG_CC_OPTIMIZE_FOR_SIZE=y
@@ -70,7 +70,6 @@ CONFIG_CLKSRC_ARM_GLOBAL_TIMER_SCHED_CLOCK=y
 CONFIG_CLKSRC_OF=y
 CONFIG_CLONE_BACKWARDS=y
 CONFIG_COMMON_CLK=y
-# CONFIG_COMMON_CLK_PXA is not set
 CONFIG_CPU_32v6K=y
 CONFIG_CPU_32v7=y
 CONFIG_CPU_ABRT_EV7=y
@@ -95,12 +94,9 @@ CONFIG_DEBUG_BCM_5301X=y
 CONFIG_DEBUG_INFO=y
 CONFIG_DEBUG_LL=y
 CONFIG_DEBUG_LL_INCLUDE="debug/8250.S"
-# CONFIG_DEBUG_LL_UART_8250 is not set
-# CONFIG_DEBUG_LL_UART_PL01X is not set
 CONFIG_DEBUG_UART_8250=y
 # CONFIG_DEBUG_UART_8250_FLOW_CONTROL is not set
 CONFIG_DEBUG_UART_8250_SHIFT=0
-# CONFIG_DEBUG_UART_BCM63XX is not set
 CONFIG_DEBUG_UART_PHYS=0x18000300
 # CONFIG_DEBUG_UART_PL01X is not set
 CONFIG_DEBUG_UART_VIRT=0xf1000300
@@ -176,6 +172,8 @@ CONFIG_HAVE_SMP=y
 CONFIG_HAVE_SYSCALL_TRACEPOINTS=y
 CONFIG_HAVE_UID16=y
 CONFIG_HAVE_VIRT_CPU_ACCOUNTING_GEN=y
+CONFIG_HIGHMEM=y
+# CONFIG_HIGHPTE is not set
 CONFIG_HZ_FIXED=0
 CONFIG_HZ_PERIODIC=y
 CONFIG_INITRAMFS_SOURCE=""
@@ -199,6 +197,7 @@ CONFIG_MTD_NAND_ECC=y
 # CONFIG_MTD_PHYSMAP_OF is not set
 CONFIG_MTD_SPI_BCM53XXSPIFLASH=y
 CONFIG_MTD_SPI_NOR=y
+CONFIG_MTD_SPLIT_SUPPORT=y
 CONFIG_MTD_UBI=y
 CONFIG_MTD_UBI_BEB_LIMIT=20
 CONFIG_MTD_UBI_BLOCK=y
@@ -247,7 +246,7 @@ CONFIG_RWSEM_SPIN_ON_OWNER=y
 CONFIG_RWSEM_XCHGADD_ALGORITHM=y
 CONFIG_SCHED_HRTICK=y
 # CONFIG_SCSI_DMA is not set
-CONFIG_SERIAL_EARLYCON=y
+# CONFIG_SECCOMP is not set
 CONFIG_SERIAL_OF_PLATFORM=y
 CONFIG_SMP=y
 CONFIG_SMP_ON_UP=y