bcm53xx: prepare for building Tenda AC9 TRX image
[openwrt/openwrt.git] / target / linux / bcm53xx / image / Makefile
index 4e3f12c82b1ab72f6a592b2c5b1c285e156e57e0..67114b813799b672c59912c9c070098beecd1cdf 100644 (file)
@@ -70,6 +70,9 @@ endef
 
 DEVICE_VARS += PRODUCTID SIGNATURE NETGEAR_BOARD_ID NETGEAR_REGION
 
+USB2_PACKAGES := kmod-usb-ohci kmod-usb2
+USB3_PACKAGES := kmod-usb-ohci kmod-usb2 kmod-usb3
+
 define Device/Default
   # .dtb files are prefixed by SoC type, e.g. bcm4708- which is not included in device/image names
   # extract the full dtb name based on the device info
@@ -91,90 +94,141 @@ define Device/asus
   IMAGE/trx := append-ubi | trx-nand | asus-trx
 endef
 
-define AsusDevice
-  define Device/asus-$(1)
-       $$(Device/asus)
-       PRODUCTID := $(2)
-  endef
-  TARGET_DEVICES += asus-$(1)
+define Device/asus-rt-ac56u
+  DEVICE_TITLE := Asus RT-AC56U
+  DEVICE_PACKAGES := kmod-b43 $(USB3_PACKAGES)
+endef
+TARGET_DEVICES += asus-rt-ac56u
+
+define Device/asus-rt-ac68u
+  DEVICE_TITLE := Asus RT-AC68U
+  DEVICE_PACKAGES := $(USB3_PACKAGES)
+endef
+TARGET_DEVICES += asus-rt-ac68u
+
+define Device/asus-rt-ac87u
+  DEVICE_TITLE := Asus RT-AC87U
+  DEVICE_PACKAGES := $(USB3_PACKAGES)
+endef
+TARGET_DEVICES += asus-rt-ac87u
+
+define Device/asus-rt-n18u
+  DEVICE_TITLE := Asus RT-N18U
+  DEVICE_PACKAGES := $(USB3_PACKAGES)
+endef
+TARGET_DEVICES += asus-rt-n18u
+
+define Device/buffalo-wxr-1900dhp
+  DEVICE_TITLE := Buffalo WXR-1900DHP
+  DEVICE_PACKAGES := $(USB3_PACKAGES)
 endef
+TARGET_DEVICES += buffalo-wxr-1900dhp
 
-define LinksysDevice
-  TARGET_DEVICES += linksys-$(1)
+define Device/buffalo-wzr-600dhp2
+  DEVICE_TITLE := Buffalo WZR-600DHP2
+  DEVICE_PACKAGES := kmod-b43 $(USB2_PACKAGES)
 endef
+TARGET_DEVICES += buffalo-wzr-600dhp2
+
+define Device/buffalo-wzr-900dhp
+  DEVICE_TITLE := Buffalo WZR-900DHP
+  DEVICE_PACKAGES := kmod-b43 $(USB3_PACKAGES)
+endef
+TARGET_DEVICES += buffalo-wzr-900dhp
+
+define Device/buffalo-wzr-1750dhp
+  DEVICE_TITLE := Buffalo WZR-1750DHP
+  DEVICE_PACKAGES := kmod-b43 $(USB3_PACKAGES)
+endef
+TARGET_DEVICES += buffalo-wzr-1750dhp
 
 define Device/dlink
   IMAGES := bin
   IMAGE/bin := append-ubi | seama-nand
 endef
 
-define DLinkDevice
-  define Device/dlink-$(1)
-       $$(Device/dlink)
-       SIGNATURE := $(2)
-  endef
-  TARGET_DEVICES += dlink-$(1)
-endef
-
 define Device/dlink-dir-885l
   DEVICE_TITLE := D-Link DIR-885L
-  DEVICE_PACKAGES := kmod-brcmfmac
+  DEVICE_PACKAGES := kmod-brcmfmac $(USB3_PACKAGES)
   $(Device/dlink)
   SIGNATURE := wrgac42_dlink.2015_dir885l
 endef
 TARGET_DEVICES += dlink-dir-885l
 
+define Device/linksys-ea6300-v1
+  DEVICE_TITLE := Linksys EA6300 V1
+  DEVICE_PACKAGES := kmod-b43 $(USB3_PACKAGES)
+endef
+TARGET_DEVICES += linksys-ea6300-v1
+
 define Device/netgear
   IMAGES := chk
   IMAGE/chk := append-ubi | trx-nand | netgear-chk
   NETGEAR_REGION := 1
 endef
 
-define NetgearDevice
-  define Device/netgear-$(1)
-       $$(Device/netgear)
-       NETGEAR_BOARD_ID := $(2)
-  endef
-  TARGET_DEVICES += netgear-$(1)
-endef
-
 define Device/netgear-r6250
+  DEVICE_TITLE := Netgear R6250
+  DEVICE_PACKAGES := kmod-b43 $(USB3_PACKAGES)
   $(Device/netgear)
   NETGEAR_BOARD_ID := U12H245T00_NETGEAR
 endef
 
 define Device/netgear-r6300-v2
+  DEVICE_TITLE := Netgear R6300 V2
+  DEVICE_PACKAGES := kmod-b43 $(USB3_PACKAGES)
   $(Device/netgear)
   NETGEAR_BOARD_ID := U12H240T00_NETGEAR
 endef
 
+define Device/netgear-r7000
+  DEVICE_TITLE := Netgear R7000
+  DEVICE_PACKAGES := $(USB3_PACKAGES)
+  $(Device/netgear)
+  NETGEAR_BOARD_ID := U12H270T00_NETGEAR
+endef
+TARGET_DEVICES += netgear-r7000
+
+define Device/netgear-r7900
+  DEVICE_TITLE := Netgear R7900
+  DEVICE_PACKAGES := kmod-brcmfmac $(USB3_PACKAGES)
+  $(Device/netgear)
+  NETGEAR_BOARD_ID := U12H315T30_NETGEAR
+endef
+TARGET_DEVICES += netgear-r7900
+
 define Device/netgear-r8000
   DEVICE_TITLE := Netgear R8000
-  DEVICE_PACKAGES := kmod-brcmfmac
+  DEVICE_PACKAGES := kmod-brcmfmac $(USB3_PACKAGES)
   $(Device/netgear)
   NETGEAR_BOARD_ID := U12H315T00_NETGEAR
 endef
 
+define Device/netgear-r8500
+  DEVICE_TITLE := Netgear R8500
+  DEVICE_PACKAGES := kmod-brcmfmac $(USB3_PACKAGES)
+  $(Device/netgear)
+  NETGEAR_BOARD_ID := U12H334T00_NETGEAR
+endef
+# TARGET_DEVICES += netgear-r8500
+
 define Device/smartrg-sr400ac
   DEVICE_TITLE := SmartRG SR400ac
-  DEVICE_PACKAGES := kmod-brcmfmac
+  DEVICE_PACKAGES := kmod-brcmfmac $(USB3_PACKAGES)
+  IMAGES := trx
+  IMAGE/trx := append-rootfs | trx-serial
+endef
+
+define Device/tenda-ac9
+  DEVICE_TITLE := Tenda AC9
+  DEVICE_PACKAGES := $(USB2_PACKAGES)
   IMAGES := trx
   IMAGE/trx := append-rootfs | trx-serial
 endef
+# TARGET_DEVICES += tenda-ac9
 
 TARGET_DEVICES += \
-       buffalo-wzr-1750dhp buffalo-wzr-600dhp2 buffalo-wzr-900dhp \
-       buffalo-wxr-1900dhp \
        netgear-r6250 netgear-r6300-v2 netgear-r8000 \
        smartrg-sr400ac
 
-$(eval $(call AsusDevice,rt-ac56u,RT-AC56U))
-$(eval $(call AsusDevice,rt-ac68u,RT-AC68U))
-$(eval $(call AsusDevice,rt-ac87u,RT-AC87U))
-$(eval $(call AsusDevice,rt-n18u,RT-N18U))
-$(eval $(call LinksysDevice,ea6300-v1))
-$(eval $(call NetgearDevice,r7000,U12H270T00_NETGEAR))
-$(eval $(call NetgearDevice,r7900,U12H315T30_NETGEAR))
-# $(eval $(call NetgearDevice,r8500,U12H334T00_NETGEAR))
-
 $(eval $(call BuildImage))