bcm53xx: added basic dts for linksys ea6500v2
[openwrt/openwrt.git] / target / linux / bcm53xx / image / Makefile
index e4dca0c4e95a6c937582eb5089a5d4e3e17a24a8..e42d612f1f684673fa80653ca076273b45ae62f2 100644 (file)
@@ -59,9 +59,7 @@ define Build/trx
 endef
 
 define Build/trx-serial
-       $(STAGING_DIR_HOST)/bin/trx \
-               -o $@.new \
-               -m 33554432 \
+       $(STAGING_DIR_HOST)/bin/otrx create $@.new \
                -f $(IMAGE_KERNEL) -a 1024 \
                -f $@ -a 0x10000 -A $(KDIR)/fs_mark
        mv $@.new $@
@@ -72,9 +70,7 @@ define Build/trx-nand
        #         if it grows up between releases
        # root: UBI with one extra block containing UBI mark to trigger erasing
        #       rest of partition
-       $(STAGING_DIR_HOST)/bin/trx \
-               -o $@.new \
-               -m 33554432 \
+       $(STAGING_DIR_HOST)/bin/otrx create $@.new \
                -f $(IMAGE_KERNEL) -a 0x20000 -b 0x400000 \
                -f $@ \
                -A $(KDIR)/ubi_mark -a 0x20000
@@ -228,13 +224,18 @@ endef
 TARGET_DEVICES += dlink-dir-885l
 
 # Linksys devices are disabled due to problem with 2 TRX partitions
-
 define Device/linksys-ea6300-v1
   DEVICE_TITLE := Linksys EA6300 V1
   DEVICE_PACKAGES := $(B43) $(USB3_PACKAGES)
 endef
 # TARGET_DEVICES += linksys-ea6300-v1
 
+define Device/linksys-ea6500-v2
+  DEVICE_TITLE := Linksys EA6500 V2
+  DEVICE_PACKAGES := $(B43) $(USB3_PACKAGES)
+endef
+TARGET_DEVICES += linksys-ea6500-v2
+
 define Device/linksys-ea9200
   DEVICE_TITLE := Linksys EA9200 V1
   DEVICE_PACKAGES := $(BRCMFMAC_43602A1) $(USB3_PACKAGES)