Add WL-700gE support (based on work by jr) Includes kernel/diag patch and a new targe...
[openwrt/openwrt.git] / target / linux / brcm-2.4 / Makefile
index 0091360c7308d7b3df350864bd0bffe169b04d59..28ee7b92058c6de07d62bc6c8f5899d927bdd80b 100644 (file)
@@ -112,4 +112,15 @@ define Profile/WLHDD/Description
 endef
 $(eval $(call Profile,WLHDD))
 
+define Profile/WL700GE
+  NAME:=WL-700gE
+  PACKAGES:=-ppp -ppp-mod-pppoe -kmod-ipt-nathelper -iptables -dnsmasq -bridge kmod-ide-core kmod-ide-aec62xx kmod-fs-ext3 fdisk e2fsprogs
+endef
+
+define Profile/WL700GE/Description
+       Minimal package set optimized for booting the WL-700gE from flash with a writable filesystem
+       and the utilities to create a new filesystem on the HDD
+endef
+$(eval $(call Profile,WL700GE))
+
 $(eval $(call BuildKernel))