remove bogus part of the broadcom target descriptions
[openwrt/openwrt.git] / target / linux / brcm-2.4 / Makefile
index 14b73f8f5cdbcd1a2ab0efea35bba648375f9b56..82bfa1bf90b6f57920cf72e2f63a9e00974e9b47 100644 (file)
@@ -6,16 +6,74 @@
 #
 include $(TOPDIR)/rules.mk
 
-LINUX_VERSION:=2.4.32
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=38f4d0830e95a20f4bfed17622d5557c
+ARCH:=mipsel
+BOARD:=brcm
+BOARDNAME:=Broadcom BCM947xx/953xx
+FEATURES:=squashfs
+
+define Target/Description
+       Build firmware images for Broadcom based routers
+       (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
+endef
+
+KERNEL:=2.4
 
-include ./config
 include $(INCLUDE_DIR)/kernel-build.mk
+DEFAULT_PACKAGES += kmod-switch kmod-diag nvram
+
+define Profile/Broadcom
+  NAME:=Generic, Broadcom WiFi (default)
+  PACKAGES:=kmod-brcm-wl wlc nas kmod-wlcompat
+endef
+$(eval $(call Profile,Broadcom))
+
+define Profile/BroadcomMimo
+  NAME:=Generic, Broadcom WiFi (MIMO)
+  PACKAGES:=kmod-brcm-wl-mimo wlc nas kmod-wlcompat
+endef
+$(eval $(call Profile,BroadcomMimo))
+
+define Profile/Atheros
+  NAME:=Generic, Atheros WiFi
+  PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
+
+define Profile/None
+  NAME:=Generic, No WiFi
+  PACKAGES:=
+endef
+$(eval $(call Profile,None))
+
+
+define Profile/WRT54G3G
+  NAME:=Linksys WRT54G3G
+  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-pcmcia-core kmod-pcmcia-serial kmod-nozomi comgt wlc nas kmod-wlcompat
+endef
+$(eval $(call Profile,WRT54G3G))
+
+define Profile/WL500G
+  NAME:=ASUS WL-500g
+  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-lp wlc nas kmod-wlcompat
+endef
+$(eval $(call Profile,WL500G))
+
+define Profile/WL500GD
+  NAME:=ASUS WL-500g Deluxe
+  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-uhci kmod-usb2 wlc nas kmod-wlcompat
+endef
+$(eval $(call Profile,WL500GD))
+
+define Profile/WL500GP
+  NAME:=ASUS WL-500g Premium
+  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 wlc nas kmod-wlcompat
+endef
+$(eval $(call Profile,WL500GP))
 
-$(LINUX_DIR)/.patched: $(LINUX_DIR)/.unpacked
-       [ -d ../generic-$(KERNEL)/patches ] && $(PATCH) $(LINUX_DIR) ../generic-$(KERNEL)/patches
-       [ -d ./patches ] && $(PATCH) $(LINUX_DIR) ./patches
-       @$(CP) config $(LINUX_DIR)/.config
-       touch $@
+define Profile/WLHDD
+  NAME:=WL-HDD
+  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-ide-core kmod-ide-pdc202xx wlc nas kmod-wlcompat
+endef
+$(eval $(call Profile,WLHDD))
 
+$(eval $(call BuildKernel))