remove bogus part of the broadcom target descriptions
[openwrt/openwrt.git] / target / linux / brcm-2.6 / Makefile
index 960c29789a60c98d33c182d182bbf4d57df8a45a..0a2575913d44f6f3e3c927d26db5351ea5ec7f9f 100644 (file)
@@ -9,23 +9,15 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=brcm
 BOARDNAME:=Broadcom BCM947xx/953xx
-FEATURES:=pci usb pcmcia squashfs jffs2
+FEATURES:=squashfs
 
 define Target/Description
        Build firmware images for Broadcom based routers
        (e.g. Linksys WRT54G(S), Asus WL-500g, Motorola WR850G)
-
-       This one builds the generic .trx images, activate one of the
-       options below for creating device specific files for use
-       with TFTP client too.
 endef
 
-LINUX_VERSION:=2.6.17
-LINUX_RELEASE:=1
-LINUX_KERNEL_MD5SUM:=37ddefe96625502161f075b9d907f21e
-
 include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-switch
+DEFAULT_PACKAGES += kmod-switch kmod-diag
 
 define Profile/Atheros
   NAME:=Atheros WiFi (default)