layerscape: add u-boot environment support for OpenWrt boot
[openwrt/openwrt.git] / target / linux / brcm2708 / Makefile
index 9d0d921738c81475a5785842ff081f82bf3f305e..3032b9ffd15095c39d79424acd8078f67f79bf04 100644 (file)
@@ -1,29 +1,34 @@
 #
 # Copyright (C) 2012-2016 OpenWrt.org
+# Copyright (C) 2017 LEDE project
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/host.mk
 
 ARCH:=arm
 BOARD:=brcm2708
 BOARDNAME:=Broadcom BCM27xx
-FEATURES:=ext4 audio usb usbgadget display gpio fpu
+FEATURES:=ext4 audio usb usbgadget display gpio fpu squashfs
 MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
 SUBTARGETS:=bcm2708 bcm2709 bcm2710
 
-KERNEL_PATCHVER:=4.4
-
-include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835 kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1
+KERNEL_PATCHVER:=4.9
 
 define Target/Description
        Build firmware image for Broadcom BCM27xx SoC devices.
        Currently produces SD Card image for Raspberry Pi.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       brcm2708-gpu-fw \
+       kmod-usb-hid \
+       kmod-sound-core kmod-sound-arm-bcm2835 \
+       kmod-fs-vfat kmod-nls-cp437 kmod-nls-iso8859-1 \
+       partx-utils mkf2fs e2fsprogs
+
 KERNELNAME:=Image dtbs
 
 $(eval $(call BuildTarget))